weixin_42315941
2009-06-18 10:59
浏览 277
已采纳

Eclipse的RCP插件怎么安装

请问大家,我下载了eclipse的RCP插件,用link的形式安装了上去,结果是有些功能得到了体现,有些没有,怎么回事?谢谢!
[b]问题补充:[/b]
我下载了eclipse-RCP-SDK-3.4.2-win32.zip,用link的形式安装了,但是在做扩展的时候,有此属性没有,而用单独的eclipse插件(Eclipse for RCP/Plug-in Developers (176 MB) )会有。。是什么问题。
[b]问题补充:[/b]
我同事,直接下载eclipse-RCP-SDK-3.4.2-win32.zip 覆盖也会有一样的问题。
[b]问题补充:[/b]
大家在RCP开发都没有碰到此问题吗?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

7条回答 默认 最新

  • wanghaolovezlq 2009-06-18 14:22
    已采纳

    eclipse-RCP-SDK-3.4.2-win32.zip解压和以下比对一下就知道了
    Eclipse for RCP/Plug-in Developers 包含以下东东:
    org.eclipse.ecf.core 2.1.0.v20081224-1728
    org.eclipse.ecf.examples 2.1.0.v20081224-1728
    org.eclipse.emf.common 2.4.0.v200902171115
    org.eclipse.emf.common.ui 2.4.0.v200902171115
    org.eclipse.emf.ecore 2.4.2.v200902171115
    org.eclipse.emf.ecore.edit 2.4.1.v200902171115
    org.eclipse.emf.edit 2.4.2.v200902171115
    org.eclipse.emf.edit.ui 2.4.2.v200902171115
    org.eclipse.epp.usagedata.feature 1.0.1.R200809220400
    org.eclipse.gef 3.4.2.v20090218-1145-67728084A56B4I233613552
    org.eclipse.mylyn.bugzilla_feature 3.0.5.v20090218-1800-e3x
    org.eclipse.mylyn.context_feature 3.0.5.v20090218-1800-e3x
    org.eclipse.mylyn.ide_feature 3.0.5.v20090218-1800-e3x
    org.eclipse.mylyn.java_feature 3.0.5.v20090218-1800-e3x
    org.eclipse.mylyn.pde_feature 3.0.5.v20090218-1800-e3x
    org.eclipse.mylyn.team_feature 3.0.5.v20090218-1800-e3x
    org.eclipse.mylyn_feature 3.0.5.v20090218-1800-e3x
    org.eclipse.platform 3.4.2.r34x_v20081010-9I96EiLElhh3qWoXHb-Nz-c-45TPOR8EvkPkYu
    org.eclipse.sdk 3.4.1.R34x_v20080827-7O7S7CC2J4xtL6jGNRbBVf_RIBeMxhHz0DfkyXrMcvME-
    org.eclipse.wst.common_ui.feature 3.0.4.v200811200248-7C78ELhE8VrRVqtHp4iT8PuSwZ5W
    org.eclipse.wst.xml_ui.feature 3.0.4.v200811211541-7F2ENnCwum8W79A1UYNgSjOcFVJg
    org.eclipse.xsd 2.4.2.v200902171115
    org.eclipse.xsd.edit 2.4.0.v200902171115

    点赞 评论
  • laitaogood 2009-06-18 11:00
    点赞 评论
  • wanghaolovezlq 2009-06-18 11:05
    点赞 评论
  • wanghaolovezlq 2009-06-18 11:45

    会不会是少了什么插件

    点赞 评论
  • laitaogood 2009-06-18 11:45

    link的安装方式会有点问题
    建议LZ还是按照插件的方式去安装吧,毕竟插件是专门为eclipse定制的,可靠性当然要更高了

    点赞 评论
  • laitaogood 2009-06-18 14:13

    [quote]大家在RCP开发都没有碰到此问题吗?[/quote]
    用安装插件的方式,没有问题

    点赞 评论
  • wanghaolovezlq 2009-06-18 14:13

    Eclipse for RCP/Plug-in Developers的插件更全面,

    纯Eclipse少了一些eclipse-RCP-SDK-3.4.2-win32.zip必须的插件

    点赞 评论

相关推荐 更多相似问题