fcp6316
2010-01-27 16:33
浏览 208
已采纳

Rails 工程在tomcat发布后tomcat报错

ruby on rails 用Jruby 打包后发布到tomcat上,tomcat正常启动,但是在和数据库通信的时候tomcat报错,一下是错误信息:
[color=red]The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again:gem install mysql.[/color]
请问这个是什么原因,是要在Jruby中安装mysql的gem文件么?
还是要用别的方法?请哪位高手给个详解~ 万分感谢!!

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • xenocide 2010-01-29 08:53
    已采纳

    首先确保你的 jruby 有 mysql gem (不打包的时候也能跑就行了,如果你用 Netbeans 开发,那默认应该包含了这个 gem)。

    打包的时候需要包含对应的 gem,先运行以下两个 rake 任务:

    rake gems:unpack
    rake gems:unpack:dependencies

    然后再打包应该就可以了。

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题