burnquist
2010-04-02 16:54
浏览 246
已采纳

在IDEA9里配置STRUTS2,服务器老是报错....

原来在myeclipse8 上用着挺舒服的,现在项目要求用IDEA9开发,IDEA9刚开始用觉得麻烦得很,完全不习惯,网上教程又少又旧,现在弄了半个下午,想用STRUTS2来实现个简单的helloworld都实现不了,老是报错:
java.lang.ClassNotFoundException: org.apache.struts2.dispatcher.Filterdispatcher
STRUTS2换了2.1、2.0两个版本也不行....
估计是不是IDEA9配置的时候少配了什么东西....麻烦得很,希望各位帮忙解决下....

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • winneryj 2010-04-02 23:25
    已采纳

    把你项目所有的jar包放到/WEB-INF/lib下。如果放在其他地方有可能会找不到。
    如果你不把jar包放在/WEB-INF/lib下的话,建议用maven来管理项目的jar包,这样就不会出现找不到jar包的问题。

    点赞 评论
  • 小坏蛋rubys 2010-04-03 14:38

    看一下 jar 的位置/IDEA 里面 classpath 的配置

    点赞 评论
  • winneryj 2010-04-03 23:06

    那就先下载一个struts2的完整zip包,在里面找到struts2-blank.2.1.*.war,把里面的文件拷贝到对应位置,看可以运行起来不。

    点赞 评论
  • winneryj 2010-04-03 23:33

    要是还不行,建project的时候,勾选Web Application中的Struts2后,idea也会自动down下需要的库的。

    点赞 评论

相关推荐 更多相似问题