take_wave
2010-08-21 22:23
浏览 782
已采纳

ANT环境中实用不同版本JDK的问题

持续集成工具。

工具本身需要jdk1.6才能运行。

工具提供自定义扩展功能,可以编写bat脚本或ant脚本。

我需要自定义ant脚本来编译java代码。编译java代码需要jdk1.5。

问题是我在自定义的bat脚本中把JAVA_HOME修改为jdk1.5,报错,jvm和jdk版本不一致...

javac标签的fork改成true,还是报错,运行javac失败。

 

ant官网查到的方法和网上介绍的方法我都试了,那些方法都不起作用啊。编译结果还是jdk1.6

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • 小毛1983 2010-08-22 07:30
    已采纳

    [code="xml"]
    classpathref="nutz-classpath" includeantruntime="false">

    classpathref="nutz-classpath" includeantruntime="false">

    [/code]
    用高版本的jdk可以编译出低版本兼容的字节码

    打赏 评论

相关推荐 更多相似问题