cxf 导入包问题

麻烦帮我看看如果要集成cxf2.2.11或其它版本还需要加入cxf的什么包。。。
我用的spring版本是2.5
谢谢各位了。。 如果有什么资料也可以发到我的邮箱 ootabc@126.com

5个回答

我指的是你在原来项目的基础上要集成cxf2.2.11,需加的那两个包,
不是说new个项目,spring集成cxf2.2.11仅仅只需要那两个包,不要误解哦。

1、《深入详解Struts2》
2、《精通Spring2.x》。
3、《深入浅出Hibernate》
4、设计模式
5、深入JAVA虚拟机
这几本本我有,1属于比较入门的,2内容挺丰富的,想深入是个不错的选择,3看的不多,4,5属于练内功的把,有时间就慢慢看,多看几篇

另可参考:
[url]http://makeitjoy.iteye.com/blog/244225
[/url]
[url]http://makeitjoy.iteye.com/blog/244286[/url]
[url]http://makeitjoy.iteye.com/blog/244293 [/url]
[url]http://makeitjoy.iteye.com/blog/244325 [/url]
[url]http://makeitjoy.iteye.com/blog/244333 [/url]
[url]http://makeitjoy.iteye.com/blog/244335[/url]

cxf-2.1.2.jar
cxf-manifest.jar

差不多够了把~

[code="java"]
rg.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Failed to import bean definitions from relative location [applicationContext-dm-cxf.xml]
[color=red]Offending resource: ServletContext resource [/WEB-INF/classes/META-INF/applicationContext.xml][/color]; nested exception is org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Unable to locate Spring NamespaceHandler for XML schema namespace [http://cxf.apache.org/jaxws]
[color=red]Offending resource: ServletContext resource [/WEB-INF/classes/META-INF/applicationContext-dm-cxf.xml] [/color]

[/code]
红色的两个文件是你加的文件还是? 不加这两个包会报错吗?

我感觉报的这个错误和加入的两个包好像没什么关系,你把包暂时去掉,看是不是还报错。~ 有可能是你spring包的问题

[quote]spring.jar包是不是一般包含了:spring-aop.jar spring-beans.jar 等包?[/quote]

是的,一般应该是包括了~

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐