weixin_39747049
weixin_39747049
2021-01-12 14:15

Permissions issue

I compiled πfs and tried to mount a directory with it:


$ ls 
bin  mdd  root
$ ./bin/πfs root -o mdd=mdd
$ cd root
-bash: cd: root: No such file or directory
$ ls -lh | grep root
d????????? ? ?    ?       ?              ? root

What's wrong?

该提问来源于开源项目:philipl/pifs

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答

  • weixin_39747049 weixin_39747049 4月前

    I use x86_64 Linux.

    点赞 评论 复制链接分享
  • weixin_39888049 weixin_39888049 4月前

    I didn't say that you did. I linked to this issue because the actual issue both of you are facing is the same. Neither of you are able to access the filesystem once it is mounted, which is the same issue I am facing as well.

    点赞 评论 复制链接分享
  • weixin_39886841 weixin_39886841 4月前

    I've tried to mount pifs and got the same issue. The reason is in pifs_getattr. It handles root pifs directory incorrectly when metadata directory specified as relative. So quick workaround: use absolute paths:

    pifs -o mdd=`pwd`/metadata/ mnt/
    
    点赞 评论 复制链接分享
  • weixin_39654058 weixin_39654058 4月前

    Mine wouldn't work with the mount path in my user's /home/username/mountpoint directory. I had to have both the mountpoint & meta directories in /mnt: /mnt/pifs/mountpoint/ & /mnt/second-hdd/pifsmeta/

    Then I was able to have it autostart using root's crontab: /usr/local/bin/πfs -o mdd=/mnt/second-hdd/pifsmeta/ /mnt/pifs/mountpoint/

    Doing this allows root access to the pifs mountpoint, but not user access unfortunately. I don't know a solution to that & will have to use the dir as root all the time. Chown user:user /path didn't work.

    点赞 评论 复制链接分享

相关推荐