被Devkit折腾的头大了

部分gem安装的时候会提示必须安装devkit工具,按照https://github.com/oneclick/rubyinstaller/wiki/development-kit文章装了无数遍,也试了不同的版本和不同的电脑,但是总是没能成功,刚学ruby,很多问题都是google,但还有很多问题根本就不知道为什么,真是迷惑啊!还有被ruby的各种gem的版本依赖和版本限制搞的头大了。。。
问题补充
补充一下,问题是这样的:
C:\DevKit>gem install rdiscount --platform=ruby
Fetching: rdiscount-1.6.8.gem (100%)
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
这个界面大概过去半个小时了,还是这样显示。

1个回答

试试gem install XXX -V,你应该能看到更多信息。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问