cherry_mogu
冰川薄荷糖
采纳率0%
2021-04-15 13:46

升级vue到3.0后npm无法使用

我在项目中把npm版本降级到了3.0后就无法使用了(已经亲测降低node版本没有用~)请问有人知道怎么解决吗?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

5条回答

  • technologist_20 技术专家团 - 流转的年华 27天前

    你好,你是用vite创建的vue3.0的项目吗,是的话需要Node.js 版本 >= 12.0.0,

    使用vue-cli创建项目的话,Vue CLI 4.x 需要 Node.js v8.9 或更高版本 (推荐 v10 以上);

    我这边Node版本是v14.16.0。vue2.0 和vue3.0都是可以用的。

    点赞 评论 复制链接分享
  • software7503 CSDN技术专家团-赖老师(软件之家) 27天前

    应该是你程序中用的其他包也要跟着升级吧。

    点赞 评论 复制链接分享
  • QA_Assistant 有问必答小助手 26天前

    非常感谢您使用有问必答服务,为了后续更快速的帮您解决问题,现诚邀您参与有问必答体验反馈。您的建议将会运用到我们的产品优化中,希望能得到您的支持与协助!

    速戳参与调研>>>https://t.csdnimg.cn/Kf0y

    点赞 评论 复制链接分享
  • zmyalh 认识则是有缘 27天前

    二话不说删除node,重新下载新版本

     

    点赞 评论 复制链接分享
  • QA_Assistant 有问必答小助手 27天前

    您好,我是有问必答小助手,你的问题已经有小伙伴为您解答了问题,您看下是否解决了您的问题,可以追评进行沟通哦~

    如果有您比较满意的答案 / 帮您提供解决思路的答案,可以点击【采纳】按钮,给回答的小伙伴一些鼓励哦~~

    ps:问答VIP仅需29元,即可享受5次/月 有问必答服务,了解详情>>>https://vip.csdn.net/askvip?utm_source=1146287632

    点赞 评论 复制链接分享

相关推荐