屋昂稽映
2021-05-19 17:38
采纳率: 100%
浏览 190

使用npx create-react-app 创建项目,npm start 报错

node环境是14.17.0,运行以前的项目(react16的版本)是可以正常运行的,就是创建新的项目不可以,会报错。

 

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

5条回答 默认 最新

  • 屋昂稽映 2021-05-19 18:41
    已采纳

    解决了。是现在react17版本创建项目的时候和AMD处理器的电脑有冲突好像。换了个package. json,把该降级的都降级就可以了。{ "name": "react-task-tracker", "version": "0.1.0", "private": true, "dependencies": { "@testing-library/jest-dom": "^5.11.4", "@testing-library/react": "^11.1.0", "@testing-library/user-event": "^12.1.10", "json-server": "^0.16.3", "react": "^17.0.1", "react-dom": "^17.0.1", "react-icons": "^4.1.0", "react-router-dom": "^5.2.0", "react-scripts": "4.0.1", "web-vitals": "^0.2.4" }, "scripts": { "start": "react-scripts start", "build": "react-scripts build", "test": "react-scripts test", "eject": "react-scripts eject", "server": "json-server --watch db.json --port 5000" }, "eslintConfig": { "extends": [ "react-app", "react-app/jest" ] }, "browserslist": { "production": [ ">0.2%", "not dead", "not op_mini all" ], "development": [ "last 1 chrome version", "last 1 firefox version", "last 1 safari version" ] } }

    打赏 评论
  • CSDN专家-林老师 2021-05-19 17:50

    路径里有中文,放在非中文路径下再次尝试。

    打赏 评论
  • CSDN专家-Time 2021-05-19 18:00

    把npm降低。看一下以前运行环境的npm

    打赏 评论
  • 「已注销」 2021-05-19 17:42

    切换一下镜像源试试

     

    打赏 评论
  • 有问必答小助手 2021-05-19 18:56

    您好,我是有问必答小助手,您的问题已经有小伙伴解答了,您看下是否解决,可以追评进行沟通哦~

    如果有您比较满意的答案 / 帮您提供解决思路的答案,可以点击【采纳】按钮,给回答的小伙伴一些鼓励哦~~

    ps:问答VIP仅需29元,即可享受5次/月 有问必答服务,了解详情>>>https://vip.csdn.net/askvip?utm_source=1146287632

    打赏 评论

相关推荐 更多相似问题