一个礼拜弄不好Eclipse maven插件。

eclipse 3.7 安装完maven插件后,控制台中提示:

 

Eclipse is running in a JRE, but a JDK is required

  Some Maven plugins may not work when importing projects or updating source folders.


启动eclipse时 弹出:

 

 

 

 

 

在网上搜,都是说 修改installed jre的路径,和修改 eclipse.ini 新增 -vm参数,我就是这么改的,但是没效果还是有警告。

 

jre 设置

 

 

 

 

 

我的eclipse.ini内容:

 

-startup

plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

--launcher.library

plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.100.v20110502

-product

org.eclipse.epp.package.jee.product

--launcher.defaultAction

openFile

--launcher.XXMaxPermSize

256M

-showsplash

org.eclipse.platform

--launcher.XXMaxPermSize

256m

--launcher.defaultAction

openFile

-vm

D:\soft\jdk1.6.0_29\bin\javaw.exe

-vmargs

-Dosgi.requiredJavaVersion=1.5

-Xms40m

-Xmx512m


还需要什么设置吗,真的没办法了,就是配不对。
查看全部
edgar108
edgar108
2012/08/08 10:26
  • maven
  • eclipse
  • 点赞
  • 收藏
  • 回答
    私信
满意答案
查看全部

0个回复