郝猿
2021-05-25 20:58
采纳率: 100%
浏览 259
已采纳

无法解析插件spring-boot-maven-plugin ?

在搭建springcloud项目的时候,配置pom文件,总是报错

无法解析插件 org.springframework.boot:spring-boot-maven-plugin: 

看了看本地仓库,确实没有相应的依赖,没下载下来

在下面再加上一个版本号,就下载下来了

<version>2.2.2.RELEASE</version>

后来我想复现一下,结果删掉以后,又不报错了。。。

难道是下载成功了以后,不指定版本号也可以?

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • 已采纳

    正常是要加版本号的,之前报错可能是网络原因,只下载了一部分。jar包没有下载到

     

    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • CSDN专家-林老师 2021-05-25 21:14

    使用springboot搭建项目会自动引入spring-boot-dependencies模块,该模块使用了dependencyManagement来管理依赖版本号,所以凡是groupId为org.springframework.boot的都不需要写版本号。

    评论
    解决 无用
    打赏 举报
  • 有问必答小助手 2021-05-26 10:56

    您好,我是有问必答小助手,您的问题已经有小伙伴解答了,您看下是否解决,可以追评进行沟通哦~

    如果有您比较满意的答案 / 帮您提供解决思路的答案,可以点击【采纳】按钮,给回答的小伙伴一些鼓励哦~~

    ps:问答VIP仅需29元,即可享受5次/月 有问必答服务,了解详情>>>https://vip.csdn.net/askvip?utm_source=1146287632

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题