水浒传鲁智深
2021-06-10 17:43
采纳率: 50%
浏览 361

ubuntu18.04安装IntelRealsense D455的SDK遇到的问题

入手了一台intel公司的 REALSENSE DEPTH CAMERA D455,

于是用官网教程:https://github.com/IntelRealSense/librealsense/blob/master/doc/distribution_linux.md

在ubuntu18.04上安装intelRealsense D455的SDK后,连接相机并运行:“realsense-viewer”,出现了以下问题:

cl@cl-ThinkPad:~$ realsense-viewer
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES
 10/06 17:20:36,820 WARNING [139899393435520] (rs.cpp:2112) null pointer passed for argument "block"
RealSense error calling rs2_gl_create_pointcloud():
    0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

,之后我在网上查了很多资料,没有相应的解决方法,请问大佬们,这是什么原因?怎么解决?

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • 王大师王文峰 2021-06-11 17:05
    已采纳

    望采纳,谢谢!、

    分析原因:glxinfo | grep"OpenGL version" 是查看OpenGL版本的命令,我在原先主机使用这个命令是可以看到有关OpenGL版本和依赖项等众多信息,但是在这台新的Ubuntu系统的主机里我并没有安装OpenGL。因此,在这里推测应该是系统的主机OpenGL版本和程序中需要使用的OpenGL版本相冲突。因此,此处给出的解决方案是卸载OpenGL和其相关的依赖项即可解决上述出现的问题。
     

    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • 有问必答小助手 2021-06-12 22:07

    您好,我是有问必答小助手,您的问题已经有小伙伴解答了,您看下是否解决,可以追评进行沟通哦~

    如果有您比较满意的答案 / 帮您提供解决思路的答案,可以点击【采纳】按钮,给回答的小伙伴一些鼓励哦~~

    ps:问答VIP仅需29元,即可享受5次/月 有问必答服务,了解详情>>>https://vip.csdn.net/askvip?utm_source=1146287632

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题