jixiang0306
2013-04-13 11:58 阅读 335
已采纳

Myeclipse 使用jdk1.7

我用的Myeclipse2013 前段时间才发布的新版本。按道理说应该能支持jdk1.7 可是我测试switch 支持String能通过。测试List list=["list"];,别的好像都能通过。

就不能通过。怎么能让Myeclipse 支持jdk1.7 该配置的我已经都配置了啊?
下面是我的配置

[img]http://dl.iteye.com/upload/attachment/0083/0926/d9a17582-83fc-312a-aaf8-62aae525c1a4.png[/img]

[img]http://dl.iteye.com/upload/attachment/0083/0928/96ce96ad-d8c1-389c-aaf3-95585264c3d0.png[/img]

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

4条回答 默认 最新

  • 已采纳
    artemisll artemisll 2013-04-13 14:47

    jdk1.7没有List list=["list"];新特性。

    http://docs.oracle.com/javase/7/docs/api/
    官网的api。

    点赞 评论 复制链接分享
  • iteye_5246 iteye_5246 2013-04-13 12:24

    简单来做不把jre 1.7 直接放在:
    D:\Program Files\MyEclipse 6.5\jre 这个目录下

    点赞 评论 复制链接分享
  • Dead_Knight Dead_Knight 2013-04-13 15:50

    特地把myeclipse2013及jdk7下载下来,结果跟你一样的问题,后来查阅官网,似乎是不支持这个特性的

    点赞 评论 复制链接分享
  • turionboy 王金豆 2013-04-13 22:08

    Myeclipse2013是基于eclipse4.2的吗。

    点赞 评论 复制链接分享

相关推荐