Allen-LuLu
2021-06-21 15:38
采纳率: 0%
浏览 177

ubuntu18vscode中安装gopls插件后项目报错

VScode安装了gopls插件后,代码报错:gopls requires a module at the root of your workspace

 

 出现上述报错后,尝试go build项目,项目能够正常运行,使用ctrl+鼠标左键,可以看到gopls插件的功能正常,能够查看函数的定义。

使用网上的方法,在settings.json文件中加入下面这段话后,

"gopls": {
    "experimentalWorkspaceModule": true
},
 

src目录中所有项目全部报错, 

而且,gopls插件的功能无法使用,ctrl+鼠标左键后点击函数无反应。

想要问问各位大佬如何解决项目报错的问题,同时保持插件gopls的功能不变。 

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

1条回答 默认 最新

  • 有问必答小助手 2021-06-24 18:18

    你好,我是有问必答小助手,非常抱歉,本次您提出的有问必答问题,技术专家团超时未为您做出解答

    本次提问扣除的有问必答次数,将会以问答VIP体验卡(1次有问必答机会、商城购买实体图书享受95折优惠)的形式为您补发到账户。

    ​​​​因为有问必答VIP体验卡有效期仅有1天,您在需要使用的时候【私信】联系我,我会为您补发。

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题