yuyongyu08
yuyongyu08
2014-03-20 23:02
浏览 201
已采纳

strut2菜鸟求解----总是404

今天搭了个struts2的工程,想研究一下,结果开始的时候还可以正常,后来也不知道怎么了总是404.工程信息如下:

1.web.xml  

<?xml version="1.0" encoding="UTF-8"?>
<web-app id="WebApp_9" version="2.4" xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">

    <display-name>Struts Blank</display-name>

    <filter>
        <filter-name>struts2</filter-name>
        <filter-class>org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter</filter-class>
    </filter>

    <filter-mapping>
        <filter-name>struts2</filter-name>
        <url-pattern>/*</url-pattern>
    </filter-mapping>

    <welcome-file-list>
        <welcome-file>index.jsp</welcome-file>
    </welcome-file-list>

</web-app>

 

 2.struts2.xml

<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE struts PUBLIC
    "-//Apache Software Foundation//DTD Struts Configuration 2.3//EN"
    "http://struts.apache.org/dtds/struts-2.3.dtd">

<struts>

    <constant name="struts.enable.DynamicMethodInvocation" value="false" />
    <constant name="struts.devMode" value="true" />

    <!-- Add packages here -->
    <package name="default" namespace="/" extends="struts-default">
        <action name="index">
            <result>/index.jsp</result>
        </action>
    </package>

</struts>

 3.jar包



 

4.Tomcat

 

 

5.JDK

jdk 1.6.0

 

运行结果:



 

后台日志:



 

 

求原因!!!!!!!!!!

 

 

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • u010120108
    天下rk 2014-03-21 10:27
    已采纳

    访问地址应该把项目名加上 localhost:8080/struts2_1/index

    点赞 评论
  • sdh888hf
    sdh888hf 2014-03-20 23:30

    action name="index" 把需要处理的java类配上去

    如下
    [code="xml"]

    /welcome.jsp
    /login.jsp

    [/code]

    点赞 评论
  • hu_2009sdu
    hu_2009sdu 2014-03-21 09:41

    1、端口问题,有没有改过tomcat端口。
    2、试试localhost:8080/index.jsp,端口号后面对应的是项目名或jsp页面

    点赞 评论
  • zxppipi
    zxppipi 2014-03-21 10:48

    访问的时候怎么不添加项目名呢?难道你部署在root下面?

    点赞 评论

相关推荐