uflyjz 2021-07-12 19:22 采纳率: 83.3%
浏览 27

PTA 数据结构-起步能力自测题 Shuffling Machine 洗牌器

用c语言写一个模拟洗牌器。按照指定的order(54个数字的有序数组,代表把这张牌洗到哪个位置)来作为洗牌规则,洗K次。
用的sample input测试完全正确。提交后结果我居然零分。实在找不出毛病。

题:
Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.
The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

Where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

我的代码:

#include <stdio.h>

int main(void)
{
    int K;
    scanf("%d", &K);
    int order[54], deck[54], temp[54];
    for (int i = 0; i < 54; i++)
        scanf("%d", &order[i]);
    for (int i = 0; i < 54; i++)
        deck[i] = i + 1;

    for (int i = 0; i < K; i++)
    {
        for (int j = 0; j < 54; j++)
            temp[order[j] - 1] = deck[j];
        for (int j = 0; j < 54; j++)
            deck[j] = temp[j];
    }

    for (int i = 0; i < 54; i++)
    {
        if (deck[i] >= 1 && deck[i] <= 13)
            printf("S%d", deck[i] % 13);
        if (deck[i] >= 14 && deck[i] <= 26)
            printf("H%d", deck[i] % 13);
        if (deck[i] >= 27 && deck[i] <= 39)
            printf("C%d", deck[i] % 13);
        if (deck[i] >= 42 && deck[i] <= 52)
            printf("D%d", deck[i] % 13);
        if (deck[i] >= 53 && deck[i] <= 54)
            printf("J%d", deck[i] % 13);
        if (i != 53)
            printf(" ");
    }

    return 0;
}

评分结果:

img

  • 写回答

1条回答 默认 最新

  • 赵4老师 2023-01-30 15:28
    关注

    边界条件
    输入输出格式
    ……

    评论

报告相同问题?

问题事件

  • 修改了问题 7月12日
  • 修改了问题 7月12日
  • 创建了问题 7月12日

悬赏问题

  • ¥15 使用C#,asp.net读取Excel文件并保存到Oracle数据库
  • ¥15 C# datagridview 单元格显示进度及值
  • ¥15 thinkphp6配合social login单点登录问题
  • ¥15 HFSS 中的 H 场图与 MATLAB 中绘制的 B1 场 部分对应不上
  • ¥15 如何在scanpy上做差异基因和通路富集?
  • ¥20 关于#硬件工程#的问题,请各位专家解答!
  • ¥15 关于#matlab#的问题:期望的系统闭环传递函数为G(s)=wn^2/s^2+2¢wn+wn^2阻尼系数¢=0.707,使系统具有较小的超调量
  • ¥15 FLUENT如何实现在堆积颗粒的上表面加载高斯热源
  • ¥30 截图中的mathematics程序转换成matlab
  • ¥15 动力学代码报错,维度不匹配