qq_41825534
小顽固哥
采纳率50%
2019-01-20 10:18 阅读 3.6k
已采纳

maven仓库导入jar包后,无法引用类

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>hadoop.hdfs</groupId>
    <artifactId>xwg.hadoop</artifactId>
    <version>1.0-SNAPSHOT</version>
<dependencies>
    <dependency>
        <groupId>org.apache.hadoop</groupId>
        <artifactId>hadoop-client</artifactId>
        <version>2.7.3</version>
    </dependency>
    <dependency>
        <groupId>junit</groupId>
        <artifactId>junit</artifactId>
        <version>4.11</version>
    </dependency>
    <dependency>
        <groupId>org.projectlombok</groupId>
        <artifactId>lombok</artifactId>
        <version>1.16.14</version>
    </dependency>
</dependencies>
<repositories>
    <repository>
        <id>cloudera</id>
        <url>https://repository.cloudera.com/artifactory/cloudera-repos</url>
    </repository>
</repositories>
</project>

以上是我的pom.xml文件

图片说明
我需要引用org.apache.hadoop-client下的FileSystem类,但是找不到图片说明

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

2条回答 默认 最新

  • 已采纳
    tavatimsa tavatimsa 2019-01-20 11:37

    你先确定导入是否正确,如果导入的时候都不正确,那肯定找不到,再看看maven库里面有没有对应该版本的jar包。你点开Lib看看该包里面有没有你要找的类,有的时候版本更新会移动类的地址。

    点赞 评论 复制链接分享
  • weixin_42031629 皇羽甫奇 2019-01-20 11:14

    图片说明
    maven刷新一下 ,或者执行命令 clean 再刷新一下

    点赞 评论 复制链接分享

相关推荐