qq_39327398
2021-07-23 14:00
采纳率: 0%
浏览 153
已结题

解决编译inkscape和sage插件时出现的缺失部分库文件问题?

我的操作步骤
1.首先在https://gitlab.com/inkscape/inkscape/tree/0.92.x
下载inkscape0.92代码,其次下载sage代码
https://github.com/riclolsen/OSHMI/tree/master/inkscape_sage_src,
将sage代码合并到Inkscape中
2.在msys2 msys中更新到最新版
3.执行msys2installdeps.sh脚本,找不到脚本中的如下四个库
img
在官网上也无法找到python2的该库文件,只有python版本的package
img
4.如果此时通过cmake在msys minw64位环境下编译则会报以下错误

img
5.如果用新版的inkscape单独可以编译成功,但加入sage代码后会因为缺少部分例如Inkscape_base的文件而导致编译失败
如何解决该问题,或者有没有方法在新版的Inkscape代码中加入sage并编译成功的方法?

  • 点赞
  • 收藏

3条回答 默认 最新

  • CSDN专家-Time 2021-07-23 14:08

    这问题只能找写库的提供的技术支持..

    点赞 打赏 评论
  • 鸡蛋酱$ 2021-07-23 14:56

    试一下把python2更新成python3

    点赞 打赏 评论
  • 王大师王文峰 2021-07-27 11:47

    采纳,这个命令过时了,
    可以试一试下面的命令
    update-core
    pacman -Syu-你可能得重复一遍,直到你看到there is nothing to do;它更新已安装的软件包。
    pacman -S mingw-w64-x86_64-python2-7xm1
    下面三个以此这样

    点赞 打赏 评论

相关推荐 更多相似问题