qq_26975307
phubing
采纳率0%
2019-01-29 14:28

Correct the classpath of your application so that it contains a single

Description:

An attempt was made to call the method org.springframework.boot.autoconfigure.web.ServerProperties$Servlet.getServletPrefix()Ljava/lang/String; but it does not exist. Its class, org.springframework.boot.autoconfigure.web.ServerProperties$Servlet, is available from the following locations:

jar:file:/D:/leaseRepository/org/springframework/boot/spring-boot-autoconfigure/2.1.1.RELEASE/spring-boot-autoconfigure-2.1.1.RELEASE.jar!/org/springframework/boot/autoconfigure/web/ServerProperties$Servlet.class

It was loaded from the following location:

file:/D:/leaseRepository/org/springframework/boot/spring-boot-autoconfigure/2.1.1.RELEASE/spring-boot-autoconfigure-2.1.1.RELEASE.jar

Action:

Correct the classpath of your application so that it contains a single, compatible version of org.springframework.boot.autoconfigure.web.ServerProperties$Servlet

springboot集成SpringCloud,子模块死活启动不起来,下面贴错误

Description:

An attempt was made to call the method org.springframework.boot.autoconfigure.web.ServerProperties$Servlet.getServletPrefix()Ljava/lang/String; but it does not exist. Its class, org.springframework.boot.autoconfigure.web.ServerProperties$Servlet, is available from the following locations:

    jar:file:/D:/leaseRepository/org/springframework/boot/spring-boot-autoconfigure/2.1.1.RELEASE/spring-boot-autoconfigure-2.1.1.RELEASE.jar!/org/springframework/boot/autoconfigure/web/ServerProperties$Servlet.class

It was loaded from the following location:

    file:/D:/leaseRepository/org/springframework/boot/spring-boot-autoconfigure/2.1.1.RELEASE/spring-boot-autoconfigure-2.1.1.RELEASE.jar


Action:

Correct the classpath of your application so that it contains a single, compatible version of org.springframework.boot.autoconfigure.web.ServerProperties$Servlet


Process finished with exit code 1

##父工程

图片说明

##子模块

图片说明

##**子模块的启动类就加了这三注解而已,没有其他的了**

@SpringBootApplication
@EnableDiscoveryClient
@EnableZuulProxy
public class GatewayApplication {
    public static void main(String[] args) {
        SpringApplication.run(GatewayApplication.class, args);
    }
}
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

1条回答

  • qq_35868811 落墨微澜 2年前

    我也是服了,为啥把我的回答删掉了。楼主这个问题我已经解决了
    原因是因为版本冲突问题
    升级springCloud版本即可

            <spring.boot.version>2.1.2.RELEASE</spring.boot.version>
            <spring.cloud.version>Greenwich.RELEASE</spring.cloud.version>
    

    我用的是 2.1.2 当然 Greenwich 支持 所有 2.1.*

    版本的

    点赞 6 评论 复制链接分享

相关推荐