Yuki_wei
绝望岛
2019-01-29 15:45
采纳率: 50%
浏览 757
已采纳

更换jdk版本之后,hibernate方法出错怎么办?

我把原来的项目jdk从原来的1.8更换到1.7之后,更换了项目里面里面的build path以及java Compiler等,在dao层hibernate中使用query.setParameter仍然报错并提示bulid path

@Override
    public int findDepartId(String d_name) {
        Session session = HibernateUtils.getSession();
        int intValue=0;
        String hql = "select d_id from Department where d_name=:name";
        Query query = session.createQuery(hql);
        query.setParameter("name", d_name);
        intValue = ((Number) query.uniqueResult()).intValue();
        session.close();
        return intValue;
    }

报错的方法

点进去path,应该没得问题

不过当我修改方法成setString可以编译,但是运行时报java.lang.NoClassDefFoundError: Could not initialize class com.wh.dao.impl.HibernateUtils
错误

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • qq_34872748
    L星火燎原 2019-01-29 15:50
    已采纳

    这个无解,只能用1.8的,JDK版本有个潜规则,高版本一般是可以兼容低版本的(重点是一般),但是低版本是绝对不能兼容高版本的。除非你代码编写环境切换成1.7的。

    点赞 评论
  • qq_37310913
    黑夜诗者 2019-01-29 16:45

    推荐使用idea,以前用eclipse各种奇葩报错,换了idea一切都变得美好了。

    点赞 评论

相关推荐