ldgyb
ldgyb
2019-01-30 16:15
采纳率: 100%
浏览 817

linux下安装pyqt4时报错:failed to determine the layout of your Qt installation

SIP已装好,版本4.19.14

安装pyqt4时,

执行 python configure.py时报错:

failed to determine the layout of your Qt installation.

请问这是什么原因呢?是还缺少什么库吗?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dawang212
    沵若成风 2019-01-30 16:55
    已采纳

    sudo apt-get install libxext6 libxext-dev libqt4-dev libqt4-gui libqt4-sql
    sudo apt-get install qt4-dev-tools qt4-doc qt4-qtconfig qt4-demos qt4-designer
    sudo apt-get install python-qt4
    sudo apt-get install python-qt4-*
    sudo apt-get install python-qscintilla2

    sudo apt-get install python3-pyqt4
    sudo apt-get install python3-pyqt4.qsci
    sudo apt-get install python3-pyqt4.qtsql
    sudo apt-get install python3-pyqt4.phonon

    用二进制方式安装,你看看缺少什么

    点赞 评论

相关推荐