zhdamsj
笨小迪
采纳率33.3%
2019-02-02 16:42 浏览 2.7k

redhat 升级glibc到2.29版本会对系统产生什么影响?

最近在迁移php的服务器,需要手动安装php编译安装所需的依赖包(运维不让用yum,贼恶心),在安装 libxml2-2.9.8-5.fc30.x86_64(安全部门要求的,要比libxml2-2.9.1-6.e17_2.3.x86_64这个版本高,说是有拒绝服务的风险,我也很无奈)的时候,报错了:

error: Failed dependencies:

    libc.so.6(GLIBC_2.28)(64bit) is needed by libxml2-2.9.8-5.fc30.x86_64
    libm.so.6(GLIBC_2.29)(64bit) is needed by libxml2-2.9.8-5.fc30.x86_64
  • 问题一:如果我按照它的提示去升级glibc到2.29版本,会对系统产生什么影响吗?因为我查了一下,有些人说系统会起不来,建议不轻易去升级这个。
  • 问题二:如果要升级glibc,那么该如何升级呢?
  • 问题三:或者下一个低一点版本的libxml2包,是不是不需要升级glibc了呢?

希望各位大神不吝赐教,再次谢过!

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

1条回答 默认 最新

相关推荐