weixin_46668875
2021-08-06 11:41
采纳率: 66.7%
浏览 55
已结题

tomcat7升级tomcat8(jdk1.7升级到jdk1.8)启动报错

eclipse在tomcat7下运行没问题,tomcat7升级tomcat8(jdk1.7升级到jdk1.8)启动报错如下:
严重: Exception sending context initialized event to listener instance of class org.springframework.web.context.ContextLoaderListener
org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 9 in XML document from class path resource [spring/applicationContext-dao.xml] is invalid; nested exception is org.xml.sax.SAXParseException; lineNumber: 9; columnNumber: 102; cvc-elt.1: 找不到元素 'beans' 的声明。
Caused by: org.xml.sax.SAXParseException; lineNumber: 9; columnNumber: 102; cvc-elt.1: 找不到元素 'beans' 的声明。

  • 好问题 提建议
  • 收藏

1条回答 默认 最新

  • 山河已无恙 2021-08-07 07:23
    已采纳

    嗯,看报错好像是配置文件少东西了,所以解析不成功,好像你的配置文件节点有问题。
    把你的applicationContext-dao.xml贴出来看看。或者排查一下,配置文件中xml格式是否正确,配置头(名称空间,前缀,约束文件xsd等)是否正确。依赖的对象名和声明的对象名是否一致,引用的类是否都存在。

    已采纳该答案
    评论
    解决 1 无用
    打赏 举报

相关推荐 更多相似问题