编程介的小学生 2019-02-20 21:26 采纳率: 20.5%
浏览 386

第m大的质因数的计算的方式,如何不排序去求解?采用C语言的计算

Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed

Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)

Output
For each line of input, your program should print a numble on a line,according to the above rules

Sample Input
4 2
5 7
123 123

Sample Output
5
0
8

  • 写回答

1条回答

  • IT学长 2019-02-21 11:39
    关注

    不知道能否有用

    #include<stdio.h>
    
    int arr[100000];
    l=0;
    void fun(int n)
    {
        int temp=n%10;
        if(temp<0) temp=-temp;
        arr[l++]=temp;
    }
    int main()
    {
        long long n,m;
        int i;
        while(scanf("%lld %lld",&n,&m)!=EOF)
        {
           double temp=1.0/n;
           double tt=1.0;
           for(i=1;i<=m;i++)
           {
               tt*=10;
           }
           temp*=tt;
           fun((int)temp);
          // printf("%lf\n",temp);
        }
        for(i=0;i<l;i++)
            printf("%d\n",arr[i]);
        return 0;
    }
    
    
    评论

报告相同问题?

悬赏问题

  • ¥15 seatunnel-web使用SQL组件时候后台报错,无法找到表格
  • ¥15 fpga自动售货机数码管(相关搜索:数字时钟)
  • ¥15 用前端向数据库插入数据,通过debug发现数据能走到后端,但是放行之后就会提示错误
  • ¥15 python天天向上类似问题,但没有清零
  • ¥30 3天&7天&&15天&销量如何统计同一行
  • ¥30 帮我写一段可以读取LD2450数据并计算距离的Arduino代码
  • ¥15 C#调用python代码(python带有库)
  • ¥15 飞机曲面部件如机翼,壁板等具体的孔位模型
  • ¥15 vs2019中数据导出问题
  • ¥20 云服务Linux系统TCP-MSS值修改?