带逻辑鬼才 2021-09-08 10:43 采纳率: 100%
浏览 285
已结题

【yolov5】TypeError: float() argument must be a string or a number, not '_NoValueType'

img

刚换上python3.8,
想跑一下yolov5
datasets里的coco128已经有了
现在出的这个错误,有没有人遇到过,我不知道哪出问题,
没往里面写过代码,就单纯运行了一下train

=====================================================

补,这块解决了,原因不知
numpy版本不对
我的numpy==1.19.2
改成1.18.5就没有这个bug
现在出了新问题

img


RuntimeError: implement_array_function method already has a docstring
============================================================
啊不对,库换成1.18.5似乎出大问题了,detect也运行不了了

img


ImportError: numpy.core.multiarray failed to import
============================================================
可能解决了,我把其他的库换成对应版本,numpy卸了重装,现在1.21.2
能跑起来了,后面我换成1.18.5再试试。
图片贴不上,太卡了,电脑跑不动这玩意,谢谢各位大。佬

requirements里面建议吧>=换成==,不然安装的版本对不上

  • 写回答

2条回答

      报告相同问题?

      相关推荐 更多相似问题

      问题事件

      • 系统已结题 9月16日
      • 已采纳回答 9月8日
      • 修改了问题 9月8日
      • 修改了问题 9月8日
      • 展开全部

      悬赏问题

      • ¥15 内存管理的一段代码不是很理解
      • ¥20 打开anaconda时卡在Loading applications无法进入界面
      • ¥15 网页超时时间设置失效
      • ¥15 有关绿色信贷毕业论文的问题
      • ¥30 关于#机器人#的问题,如何解决?
      • ¥15 求MATLAB函数ScalarLayerDisplay的代码
      • ¥15 安卓如何自动执行检测到的NFC标签,无需再点确认
      • ¥15 pyHM库mouse模块的ValueError错误
      • ¥15 python opencv 摄像头 传感器
      • ¥30 eMMC&Android&C&Linux