cookie4tracy
2021-09-17 15:35
采纳率: 100%
浏览 81
已结题

jdk-17和Java-14.0.2适配吗

初学Java 跟着视频在eclipse官网下载了jre,在jre里下载了Java-14.0.2
但后来学校还要学jsp 得配置jdk 到Oracle官网下载了jdk-17版本,跟我现在电脑的Java适配吗

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

5条回答 默认 最新

  • c developer 2021-09-17 15:42
    最佳回答

    现在用的最广泛的jdk版本是1.8,所以建议用1.8就够了,当然也可以考虑学习下jdk11的新特性,而jdk17是刚开始发行的,还没多少地方在用。另外的话,找工作不会问你jdk版本之间的区别,只会问你怎么完成面某个需求啥的,所以打好基础很关键的。

    评论
    解决 无用
    打赏 举报
查看更多回答(4条)