怀疑react和相关组件版本不兼容 5C

怀疑react配置冲突,请帮忙看下

 "dependencies": {
    "ajv": "^6.0.0",
    "assets-webpack-plugin": "^4.0.0",
    "autoprefixer": "*",
    "babel-plugin-syntax-dynamic-import": "^6.18.0",
    "babel-preset-es2015": "^6.24.1",
    "babel-preset-react": "^6.23.0",
    "color-picker": "0.0.1",
    "enzyme-adapter-utils": "^1.8.1",
    "fs": "0.0.1-security",
    "grid-styled": "^5.0.2",
    "highlight": "^0.2.4",
    "html-loader": "*",
    "js-parse-markdown-metadata": "github:ryankharris/js-parse-markdown-metadata",
    "js-yaml": "^3.12.0",
    "less": "3.0.4",
    "metamd": "github:chrisjaure/metamd",
    "net": "^1.0.2",
    "parse-markdown-metadata": "github:raininglemons/parse-markdown-metadata",
    "plantuml-encoder": "^1.2.5",
    "postcss-cli": "^2.5.0",
    "postmate": "^1.4.7",
    "processmaker": "^0.1.1",
    "prop-types-extra": "^1.1.0",
    "rc-steps": "^3.3.0",
    "react": "^15.6.2",
    "react-bootstrap": "^0.32.4",
    "react-bootstrap-table": "^4.3.1",
    "react-dnd": "^2.1.4",
    "react-dom": "^15.5.0",
    "react-input-autosize": "^2.2.1",
    "react-markdown": "^4.0.3",
    "react-modal": "^3.6.1",
    "react-overlays": "^0.8.3",
    "react-redux": "^5.0.7",
    "react-router": "^4.3.1",
    "react-router-dom": "^4.3.1",
    "react-s-alert": "^1.4.1",
    "react-select": "^2.1.1",
    "react-slide-deck": "^0.2.3",
    "react-stepper-horizontal": "^1.0.11",
    "react-table": "^6.8.6",
    "react-tabs": "^2.3.0",
    "request": "^2.88.0",
    "reveal.js": "github:hakimel/reveal.js",
    "shelljs": "^0.5.3",
    "squire-rte": "^1.9.0",
    "tls": "0.0.1",
    "tui-color-picker": "^2.2.0",
    "tui-editor": "file:tui-editor",
    "webpack": "^3",
    "webpack-notifier": "^1.5.1"
  },
  "devDependencies": {
    "assert": "^1.4.1",
    "circular-dependency-plugin": "^4",
    "deep-freeze": "0.0.1",
    "enzyme": "^3.3.0",
    "enzyme-adapter-react-15": "^1.1.1",
    "eslint": "^4.18.2",
    "eslint-plugin-react": "^7.7.0",
    "json-diff": "^0.5.2",
    "karma": "^2.0.0",
    "karma-chrome-launcher": "^2.2.0",
    "karma-coverage": "^1.1.1",
    "karma-mocha": "^1.3.0",
    "karma-sinon": "^1.0.5",
    "karma-webpack": "^2.0.13",
    "mdx-deck": "^1.7.7",
    "mocha": "^5.0.1",
    "react-test-renderer": "^15.6.1",
    "redux-freeze": "^0.1.5",
    "redux-mock-store": "^1.5.1",
    "sinon": "^4.4.2",
    "webpack-dev-server": "^2"
  }

1个回答

这个头很大,可以用REACT 脚手架重新生成项目,然后一一比对并用npm 在新项目中安装没有组件。或者与之前可行的版本比较,改成可行的版本号,不要瞎升级。用npm 升级不会自动帮你解决依赖冲突。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐