celery启动worker时说redis版本太低

图片说明
我用django的celery时把redis作为broker然后启动worker时一直报错说我redis的版本是3.1可我启动的redis就是3.2.1的,大佬们这是为什么呀

2个回答

看看进程中运行的redis3.2.1的ip和端口号,是不是127.0.0.1:6379 ,是不是哪个虚拟环境安装并打开了个3.1.0版本redis?最简单的办法就是卸载redis3.1.0,然后重新指定版本安装redis

重装3.2.0版本以上的redis就行了啊,先卸载:pip uninstall redis 然后安装:pip install redis==3.2.0

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问