求教!安装kaldi,make时错误提示没有安装libtool和python2.7,但是已经安装了。

在虚拟机linux系统,ubuntu18.0.4下安装,指令如下,请教怎么解决这个问题,谢谢!

~/kaldi-trunk/tools$ make
extras/check_dependencies.sh
extras/check_dependencies.sh: libtool is not installed.
extras/check_dependencies.sh: python 2.7 is not installed
extras/check_dependencies.sh: we recommend that you run (our best guess):
sudo apt-get install libtool python2.7
Makefile:31: recipe for target 'check_required_programs' failed
make: *** [check_required_programs] Error 1
~/kaldi-trunk/tools$ sudo apt-get install libtool python2.7
正在读取软件包列表... 完成
正在分析软件包的依赖关系树

正在读取状态信息... 完成

libtool 已经是最新版 (2.4.6-2)。
python2.7 已经是最新版 (2.7.15~rc1-1ubuntu0.1)。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 42 个软件包未被升级。
lihao@lihao-virtual-machine:~/kaldi-trunk/tools$ make
extras/check_dependencies.sh
extras/check_dependencies.sh: libtool is not installed.
extras/check_dependencies.sh: python 2.7 is not installed
extras/check_dependencies.sh: we recommend that you run (our best guess):
sudo apt-get install libtool python2.7
Makefile:31: recipe for target 'check_required_programs' failed
make: *** [check_required_programs] Error 1

0
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
【kaldi】Kaldi+CUDA安装向问题(含libtool is not installed.的解决方法)
现在汇总一下出现的问题。 (1)Ubuntu 16.04 更新Nvidia驱动后,图形登录界面无限循环 A:目前(请右上看眼发文时间),最新版本的Ubuntu 16.04不兼容Nvidia驱动。14.04或者14.10版本是安全的。这里,提供一个站点:厦门大学的信息与网络中心。里面有很多linux版本。有Deepin/CenOS/ubuntu等。 (2)虚拟机是(几乎)无法调
kaldi安装错误最终版
相信关注我博客的人知道,之前我已经把kaldi出现的错误写了博文。这次主要因为我之前的电脑内存不够,换了个稍微大点的内存,在这里提醒下学习kaldi的各位朋友,注意kaldi所需要的电脑配置,以下是我的一些看法:         1.自己的电脑系统最好是64位,包括win7和unbuntu都是64位,只有这样,你的内存才能合理利用,不会出现蹦的情况;          2.最后有GPU,最好还
语音识别系统之kaldi-----安装出现的错误
这几天看到很多人安装kaldi,但是总是在安装的时候一步不能成功。这个原因也比较简单,都是由于自己的linux未配置好。下面我把常见的两个未配置的软件放在这里,也算为安装kaldi做一个归纳。以后kaldi关于安装的问题应该问题不大了。    第一个错误是:which aclocal make :***[check_required_programs] error 1             
[Linux] 安装软件时make gcc找不到错误
[Linux] 安装软件时make gcc找不到错误
Centos安装jpeg-6b 错误提示 ./libtool 命令未找到
root@bogon jpeg-6b]# make; make install ./libtool --mode=compile gcc -O2 -I. -c ./jcapimin.c make: ./libtool:命令未找到 make: *** [jcapimin.lo] 错误 127 ./libtool --mode=compile gcc -O2 -I. -c ./cjpeg.c ma
已经安装python2.7的条件下安装anaconda
问题描述:在anaconda之前已经安装python2.7,用来做开发的。现在想装anaconda(python3.6),并使用TensorFlow。安装anaconda本身没什么问题,但cmd下输入python,发现还是之前的python2.7。尝试将anaconda目录下的python.exe改为python3.exe,却导致jupyter-notebook、Spyder启动闪退情况。 解决...
为什么已经安装了pillow但是import还会出现NameError
python 版本 2.7.15pillow(5.1.0)
已经安装了MSXML6.0,但是安装office2010时还是提示没有安装
这个方法是我自己电脑多次安装office2010一直提示没有安装MSXML6.0  。并且安装了之后还是提示这个问题,于是结合网上的各种办法,自己总结出来的解决办法,是否合理还待验证,不过我的确实用这个办法成功了,系统也没有任何异常,仅供参考。 可以先试试百度经验的方法,链接http://jingyan.baidu.com/article/a948d6517babeb0a2ccd2e71.htm
如果您的电脑已安装JDK,但是打开eclipse仍然会报错误提示
如果您的电脑已安装JDK,但是打开eclipse仍然会报以下错误提示: 原因分析 找不到JVM 解决办法 打开当前目录下的eclipse.ini文件,编辑添加以下内容 -vmargsC:\Program Files (x86)\Java\jdk1.8.0_101\bin备注:红色部分为当前电脑实际JDK的安装路径...
win7 64位系统运行cmd命令行,安装python后依然找不到的问题
环境变量没设置好。 在控制面板、系统、高级、环境变量、系统变量,在path的最后先加个分号(前面的是以前设置的别的东西的),然后加上你的C:\Pyhon之类的路径来启动你的python.exe
kaldi安装以及错误处理
首先下载kaldi包 git clone https://github.com/kaldi-asr/kaldi.git 然后安装依赖库 进  cd tools  tools文件 运行  ./extras/check_dependencies.sh 根据它要求安装 各种库  我的是缺这些: sudo apt-get install zlib1g-dev libtool subversion l...
Python使用wxPython报错解决方法
Python使用wxPython报错解决ImportError: /usr/local/lib/wxPython-3.0.2.0/lib/python2.6/site-packages/wx-3.0-osx_carbon/wx/_core_.so: no appropriate 64-bit architecture (see "man python" for running in 32-bit mode)
明明已经安装了某个模块,python报错:ImportError: No module named ***
笔者初学python,碰见一些坑,分享出来,节约大家时间: 1、错误信息如下: ImportError: No module named numpy 如果什么都没装,请出门右转,通过pip安装numpy即可!命令如下: pip install numpy 如果连pip都没有,请先安装pip!命令如下: sudo apt-get install python-pip
linux下安装python后无法执行错误解决
安装后,运行出现“./python: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory” 1、打开/etc/ld.so.conf文件libpython2.7.so.1.0所在的路径,我这里是/usr/local/l
Kaldi在虚拟机里面安装
虚拟机: Ubuntu 14.04     Ubuntu下载地址   gcc 建议安装4.8以上版本 ,登陆最好是root, 废话不多说,开始,首先安装虚拟机,  虚拟机安装  , 完成的示意图,快捷键Ctrl+Alt+t打开终端: 在终端中键入sudoapt-get update 命令然后输入密码 回车 kaldi项目现在托管在github上,需要使用g
为什么已安装模块,导入时却报错
可能是因为相同文件夹下,有以模块名命名的py文件!!!
pip装了一个包,但是python里Import的时候找不到怎么办?
通常作为没有管理员权限的用户,在服务器上用Pip装包需要装到自己Home底下(过程见上篇)。 有时候装了之后找不到这个包,import不进来,no module named xxx, 为什么呢?因为虽然装到了一个路径底下,但是Python找不到这个路径,这个时候需要改环境变量。 例如,在.bashrc中加一行 export PYTHONPATH=$PYTHONPATH:"/h
Tensorflow安装后依然提示找不到module
重新执行一遍以下命令即可: pip install --upgrade https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.3.0-py3-none-any.whl
Mac OS X系统安装GNU Autoconf,Automake和Libtool构建工具来生成makefiles和动态库
Mac OS X系统安装GNU Autoconf,Automake和Libtool构建工具来生成makefiles和动态库,命令行如下:curl -OL http://ftpmirror.gnu.org/autoconf/autoconf-2.69.tar.gz tar -xzf autoconf-2.69.tar.gz cd autoconf-2.69 ./configure && make &
安装matplotlib所需的numpy、python、six(python27)
numpy-1.9.1-win32-superpack-python2.7 python-dateutil-2.4.2.tar six-1.9.0.tar
kaldi重新编译报错
这个其实只是记录一下,之前用过,忘了,刚才郁闷了半个小时如果我们想修改部分源码,只需要编译改的那部分就好了,比如编译gmmbin下的某个文件,不过这时候改完需要三个步骤,报错主要是忘了depend.error:gmm-init-mono.o: In function `kaldi::ReadSharedPhonesList(std::__cxx11::basic_string<char, std::
jupyter中提示没有某种安装包,但安装时提示已经安装
对于ubuntu系统,首先,将原来安装到/usr/lib/python2.7/dist-packages的包卸载:pip uninstall <例如tqdm>然后,使用anaconda目录下的pip重新安装:sudo /usr/local/anaconda2/bin/pip install <例如tqdm>最后,查看anaconda下面的包,发现了tqdm的踪影:conda list
已安装Framework4.0,仍提示没有安装Framework4.0问题
部分电脑安装Framework4.0成功,但运行4.0程序时仍提示未安装Framework4.0(Win7上再安装4.5后仍不管用)。碰到有该问题的电脑占极少数 原因: 文件 %windir%\system32\mscoree.dll 或(和)%windir%\SysWOW64\mscoree.dll在安装过程中未能应用对应高版本的文件,仍就是V2.0.*版或其他低版本,出现这种情况的原因是安
【已解决】WIN7 64位系统,安装opencv-python成功后,import cv2 报错“找不到指定的模块”
在度娘上搜索了两天,找到了各种说法,最终解决问题的办法只有一个,操作步骤如下: 1、下载depends工具,在python包安装路径找到cv2.cp37-win32.pyd文件,工具会扫描系统中缺失哪些cv2必要dll文件。我的win7是缺失:api-ms-win-downlevel-shlwapi-l1-1-0.dll 2、度娘下载api-ms-win-downlevel-shlwapi-l1-...
Python2.7 安装numpy报错解决方法
Windows 10下用pip安装numpy包报错: Microsoft Visual C++ 9.0 is required Unable to find vcvarsall.bat
解决已安装python2.7 来安装python3.5的共存和安装问题及Anoconda安装及搭建:cpu的TensorFlow,Keras
首先背景win10的64位,我已经安装python2.7.10在C盘 介绍一下pycharm可以支持2.7和3.5 Anoconda仅支持3.5 python3.5自带pip不用下载,不用python2.7这么麻烦 /我这个方法和别人不一样,不删除任何东西,python2.7不删,环境变量python2.7和3.5两个,反正行了就好/ 因为最近学习keras神经网络API调用—MNIST数据集 它...
小白问:我用pip安装了request并用pycharm import 为什么无法使用
我用pip安装了request并用pycharm import 为什么无法正常使用,是安装的不对还是pycharm设置不对还是代码写的有问题? 求大神 import request url=&quot;http:/www.baidu.com&quot; r=request.GET(url) r.cookies[&quot;example_cookie_name&quot; ] pycharm上出的结果: Tra...
已经通过终端安装了第三方包,但pycharm中出现No module named XXX,找不到包
已经通过终端安装了第三方包,但pycharm中出现No module named XXX,找不到包 记录一个自己遇到的问题: 在测试混合整数规划时,用到了一个叫cvxpy的包,在pycharm的Project Interpretater中又安装不了,提示平台不匹配。无奈只有去下载源码安装。在cmd中安装好,并测试了import没有问题后,回到pycharm。import时报错 No modu...
python安装pygame出现问题的解决办法
之前的安装步骤我是参照下面这篇博客写的,https://blog.csdn.net/qq_33166080/article/details/68928563 由于原博客有广告,所以我直接摘取其中的有用信息。 PyGame的介绍                ①  Pygame 是一组用来开发游戏软件的 Python 程序模块,基于 SDL 库的基础上开发。允许你在 Python 程序中创建...
关于python安装模块之后pychram仍然提示没有安装模块的问题
    首先说一下导致这个问题的原因,安装了python2/3的电脑又安装pyhcram,在用pychram导入模块的时候都会遇到这个问题,是因为这个时候你的电脑安装了两个python解释器,pychram自带python解释器,所以你在电脑命令行用pip命令安装了模块,是安装在你电脑的python2/3而非pychram的python解释器。    知道了问题的根源,解决起来就容易了。    有...
“本地已安装selenium后,使用Pycharm导包显示失败”的解决方法
参考链接https://blog.csdn.net/weixin_42262463/article/details/80524187
安装erlang后无法安装RabbitMQ怎么办
HELP! 安装erlang后无法安装RabbitMQ怎么办? 如图已经安装好erlang并配置了环境变量;可是安装rabbitmq依旧报检测不到erlang环境是怎么回事?
同一台电脑上安装python3.5和python2.7及安装时一些工具包的方法
今年暑假开始学习Python。Python的便利性不再赘述。今天只说安装。 本来觉得网上的资源和方法很多,自己没必要写出来,可是anaconda装好也就一个月,python2.7也就四五天,今天要再装个图像处理类库,就要忘了怎么弄了,记性被dog吃了,所以觉得还是有必要写下来自己怎么装的,过程中遇到了哪些问题。以便日后看。 一、 1、首先说装python3.5吧。同学分享给我anaconda
kaldi 安装
一、预习安装包(系统Ubuntu) #install some package first sudo apt-get install libtool sudo apt-get install autoconf sudo apt-get install wget sudo apt-get install perl sudo apt-get install subver
Python 已经下载matplotlib 但是还是import错误 ,版本问题
用户回答回答于 22 天前2018-08-03 09:58:37如果有人仍然有这个问题,并重新安装bbackports.functools_lru_ ,缓存不起作用,就像在我的例子中一样,那么安装较早版本的matplotlib可能会工作。例如:pip install matplotlib==2.0.2 赞0评论0收藏0分享 如果有人仍然有这个问题,并重新安装bbackports.functools...
&1. kaldi学习之路 之 kaldi的安装编译
作为一名研究生,主攻语音识别,实验室只有自己一个人做模式识别方向,所以很苦逼。自入学来自己一人在语音识别领域痛苦挣扎,看了很多篇论文,语音识别领域质量较高的文章大多数还是英文的比较靠谱,看了几个月的论文终于有点头绪了,找到了自己的创新点,开始打算用Tensorflow训练实验,后来经多方人士推荐语音这块还是用Kaldi更好,因为语音识别不仅仅是训练几层神经网络就可以的,训练之前还需要声音信号处理,
安装pandas遇到的问题
1.安装pandas包后出现问题。安装成功后,import pandas,出现如下错误ValueError: numpy.dtype has the wrong size, try recompiling. Expected 52, got 56 这个需要升级你的numpy包,我直接升级,easy_install --upgrade numpy出错,试验了两次都是失败。然后我先卸载numpy,再
Kaldi在ubuntu 18.04下编译小结
先占个坑,说第一个遇到的问题。 sctk-2.4.10-20151007-1312Z.tar.bz2 这个文件在https://github.com/kaldi-asr/kaldi 中下载是通过tools/Makefile 文件中该行实现的 sctk-2.4.10-20151007-1312Z.tar.bz2:        wget -T 10 -t 3 ftp://jaguar.ncs...
python2.7.5安装---zlib死活装不上的解决办法
安装zlib-1.2.3.tar.gz tar -zxvf zlib-1.2.3.tar.gz ./configure 然后 vi Makefile 找到 CFLAGS=-O3 -DUSE_MMAP 在后面加入-fPIC,即变成CFLAGS=-O3 -DUSE_MMAP -fPIC 接下面步骤 make make install,然后在编译安装python即可。
#安装tensorflow的血泪史
作为一只小白,在安装tensorflow的时候出现了各种问题……希望有一些和我出现同样问题的人可以少走一点弯路……鉴于我是用pip安装(即python2.7,如果是更高版本用pip3),在这里只提供pip在OS X上安装的方法。     系统:OS X 10.13,安装的python2.7,tensorflow1.3.0,bazel0.7.0     安装tensorflow的步骤可以参考中文
文章热词 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型 设计制作学习
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 python2.7教程 python2.7学习

相似问题

0
求教!安装kaldi,make时错误提示没有安装libtool和python2.7,但是已经安装了。
1
运行python批处理文件,报了一个缺少属性“key”错误,找到源码但是看不懂,求大佬们解答
1
Python调用dll时报错OSError: [WinError 126] 找不到指定的模块。
0
用anaconda prompt的conda命令时总是报错“此时不应有\Microsoft”
6
使用Django+vue+element-ui搭建项目时,element-ui的样式不生效,如何解决?
1
安装stanford corenlp,python语言调用corenlp,系统找不到指定文件
1
django 用url传递一个参数时无法成功
1
pyspark报缺少zlib库,但是python可正确运行
2
运行批处理文件时遇到“IndentationError: unexpected indent”的错误
0
爬虫使用beautiful soup4时遇到Your browse does not support frame!,新手求解决
1
为啥在jupyter运行没有结果
0
求教如何用Python调用虹软2.0输出人脸信息
3
装了PyQt4,import能导入,但pip list里没有,pycharm里也找不到,请问谁知道是什么情况?
0
在VS2017里开发Django项目,在views.py里写中文时提示编码错误
1
求教使用python怎样对本地的未读邮件进行分析。
1
关于django runserver的问题,求教各路神仙,小生百度了半天也没有解决.
3
Python飞机大战,while无限循环,不显示图像,但是把最后quit代码放进循环内就显示了,这是为什么啊
0
安装jupyter notebook 无法连接至服务
0
“conda install 压缩包的名字”,压缩包路径正确,但是patherror提示路径不存在
0
不加阈值可以正常运行,当我想在输出层增加一个阈值判断,但是疯狂报错了,如何解决?