IntelliJ idea(2018.3.5) 启动tomcat(8.5)控制台乱码

windows 10 系统,在IDEA中,catalina.bat 不设置编码格式,控制台乱码,如下图:

图片说明

设置为GBK时,控制台不会乱码,但是项目访问服务器,获取到的session信息乱码。如下:

图片说明

即不能同时正常显示,网上说的那些方式基本都已经尝试了,无效。

3个回答

页面编码一般为UTF-8,你换成GBK肯定会乱码。
控制台乱码是因为你tomcat的日志编码跟系统的控制台编码不一样,你试试这个方法
找到你tomcat的安装目录,找到conf下的logging.properties,把下面这行注释掉,默认用控制台的编码输出日志
图片说明

m0_37872413
Alice_Asuna 回复弗里德姆: 控制台乱码解决了吗?没解决,你可以试试:Run→Edit Configuration→tomcat server→server下面有一个VM Opition选项,把这个去掉,什么都不填就行了,我就是这样解决的
7 个月之前 回复
out_of_it_farmer
弗里德姆 回复: 额。。。发现这样配置,只是启动tomcat部分不乱码了,下面程序打印的日志还是乱码
7 个月之前 回复
out_of_it_farmer
弗里德姆 多谢,有用。之前我没有配置logging.properties中的编码,现在我配置为GBK,解决了idea控制台乱码的问题。tomcat的vm options添加-Dfile.encoding=UTF-8,解决从服务器获取session乱码问题。
7 个月之前 回复

首先要分清是tomcat日志编码,与idea的日志显示控制台编码
tomcat日志编码:cmd内 "cd /d tomcat根目录" "bin\catalina.bat run" 运行,"chcp65001"切换cmd为utf8,"chcp 936"切换cmd为gbk,确定tomcat日志编码,一般因为tomcat/conf/logging.properties java.util.logging.ConsoleHandler.encoding = UTF-8已设置为utf8
idea显示编码:windows默认用gbk所以idea显示默认为gbk编码,【一定】在 Help-- custom vm options 添加-Dfile.encoding=UTF-8,强制为utf8编码显示,不要自己改.vmoptions可能位置不对,idea会在用户目录复制一个
【切忌】自己改tomcat的logging.properties 为GBk 会导致调试时get/post参数乱码

u014260748
kris_cc 哇太棒了,讲的很清楚,要搞清楚Tomcat的日志配置和IDEA的控制台显示配置,才能解决问题啊
25 天之前 回复

图片说明
你试试这些方法

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!