liuqin1998
liuqin1998
2019-03-15 20:38

机械学习配置环境的时候遇到的问题

10
  • python
  • 开发语言

之前的时候是按照这个文章的说法配置的就是这个

但是最后一步的时候开始报错,我的python是2.7的版本






nekonlaa@nekonlaa-G3-3579:~bits$ .bits-devserver
  ___ ___ ___ ___ _____ ___
 |   \_ _/ __|_ _|_   _/ __|
 | |) | | (_ || |  | | \__ \
 |___/___\___|___| |_| |___/ 6.1.1

/usr/local6b/python2.7/dist-packages/requests/__init__.py:91: RequestsDependencyWarning: urllib3 (1.24.1) or chardet (2.3.0) doesn't match a supported version!
  RequestsDependencyWarning)
A valid Caffe installation was not found on your system.
Use the envvar CAFFE_ROOT to indicate a valid installation.
Traceback (most recent call last):
  File "/usr6b/python2.7/runpy.py", line 174, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr6b/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/home/nekonlaabitsbits/__main__.py", line 70, in <module>
    main()
  File "/home/nekonlaabitsbits/__main__.py", line 53, in main
    import digits.config
  File "digits/config/__init__.py", line 7, in <module>
    from . import (  # noqa
  File "digits/config/caffe.py", line 230, in <module>
    executable, version, flavor = load_from_path()
  File "digits/config/caffe.py", line 54, in load_from_path
    raise ValueError('Caffe executable not found in PATH')
ValueError: Caffe executable not found in PATH
  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

1条回答