bk2014111825 2021-10-11 20:45 采纳率: 80%
浏览 499
已结题

关于flask_sqlalchemy中column 、Integer等方法无法使用问题

使用flask_sqlalchemy建议orm关联,使用类创建模型后,pycharm无法弹出其他db.Column或是db.Integer等方法。
问题:是flask_sqlalchemy版本不对吗,从2.0到最新的2.5.1版本都install尝试过,没有一个版本可以使用以上方法。db.Column或是db.Integer处于黄色状态,代码无法运行
请问是flask框架目前就无法使用数据库了吗,是版本问题还是,如果是,给出正确的版本、操作和代码示例

源码如下:


```python

from flask import Flask
from flask_sqlalchemy import SQLAlchemy

'''
flask_mysqldb
flask_sqlalchemy
'''
app = Flask(__name__)

'''配置数据库'''
app.config['SQLALCHEMY_DATABASE_URI'] = 'mysql://root:123456@127.0.0.1:3306/xiaoyaoji'
app.config['SQLALCHEMY_TRACK_MODIFICATIONS'] = False   #动态追踪修改

db = SQLAlchemy(app)

class Role(db.Model):
    __tablename__ = 'roles'

    id = db.Column(db.Integer, primary_key=True)
    name = db.Column(db.String(12), unique=True)

class User(db.Model):
    __tablename__ = 'users'

    id = db.Column(db.Integer, primary_key=True)
    name = db.Column(db.String(12), unique=True)
    role_id = db.Column(db.Integer, db.ForeignKey('roles.id'))


@app.route('/')
def index():
    return 'hello flask'

if __name__ == '__main__':
    db.drop_all()
    db.create_all()
    app.run(debug=True)

```

  • 写回答

4条回答 默认 最新

  • 关注

    找到原因了,SQLAlchemy包的版本要升级为1.4.25

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(3条)

报告相同问题?

问题事件

  • 系统已结题 10月20日
  • 已采纳回答 10月12日
  • 创建了问题 10月11日

悬赏问题

  • ¥20 delta降尺度方法,未来数据怎么降尺度
  • ¥15 c# 使用NPOI快速将datatable数据导入excel中指定sheet,要求快速高效
  • ¥15 再不同版本的系统上,TCP传输速度不一致
  • ¥15 高德地图点聚合中Marker的位置无法实时更新
  • ¥15 DIFY API Endpoint 问题。
  • ¥20 sub地址DHCP问题
  • ¥15 delta降尺度计算的一些细节,有偿
  • ¥15 Arduino红外遥控代码有问题
  • ¥15 数值计算离散正交多项式
  • ¥30 数值计算均差系数编程