Charles_Andrew 2021-10-13 22:28 采纳率: 76.1%
浏览 38
已结题

杭电oj 1004解答问题

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

public static void main(String args[]) {
        Scanner input = new Scanner(System.in);
        while (input.hasNext()) {
            String[] array = new String[105];/*记颜色*/
            int[] str=new int[105];/*数量*/
            int count = input.nextInt();
            if(count==0)break;
            int b=0;
            for (int num=0; num<count; num++) {
                String word= input.next();
                int judge=0;
                if (num==0){
                    array[b]=word;
                    str[b++] += 1;
                    judge=1;
                }
                for(int a=0;a<num;a++){
                    if(word.equals(array[a])){
                        str[a] += 1;
                        judge=1;
                        break;
                    }
                }
                if (judge==0){
                    array[b]=word;
                    str[b++] += 1;
                }
            }
            int max=0;
            for (int num=1;num<b;num++){
                if (str[num]>str[max]) max=num;
            }
            System.out.println(array[max]);
        }
    }

大家可以帮我看看吗?带入示例是对的,自己试了几组数据也是对的但提交时WA。

  • 写回答

1条回答 默认 最新

  • 心怀啊 2021-10-14 00:14
    关注

    给你另一种思路吧,利用hashmap,颜色为key,数量为value,每一组统计完成后遍历key得到最大的value

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

问题事件

  • 系统已结题 10月22日
  • 已采纳回答 10月14日
  • 修改了问题 10月13日
  • 创建了问题 10月13日

悬赏问题

  • ¥15 一道python难题2
  • ¥15 一道python难题
  • ¥15 用matlab 设计一个不动点迭代法求解非线性方程组的代码
  • ¥15 牛顿斯科特系数表表示
  • ¥15 arduino 步进电机
  • ¥20 程序进入HardFault_Handler
  • ¥15 oracle集群安装出bug
  • ¥15 关于#python#的问题:自动化测试
  • ¥20 问题请教!vue项目关于Nginx配置nonce安全策略的问题
  • ¥15 教务系统账号被盗号如何追溯设备