编程介的小学生 2019-03-25 17:14 采纳率: 20.5%
浏览 504

因数质因数的分解的问题的算法怎么利用C语言的程序来实现的呢?

Problem Description
You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequenace of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called easy''. Other sequences will be calledhard''.

For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

BB
ABCDACABCAB
ABCDABCD

Some examples of hard sequences are:

D
DC
ABDAB
CBABCBA

Input
In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

For example, with L = 3, the first 7 hard sequences are:

A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA
As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

ABAC ABA
7
Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

Sample Input
30 3
0 0

Sample Output
ABAC ABCA CBAB CABA CABC ACBA CABA
28

  • 写回答

1条回答 默认 最新

  • a81836620 2019-03-25 17:21
    关注
    
    #include <stdio.h>
    int S[100];
    int n,l;
    int cnt;
    int dfs(int cur) {
        if(cnt++ == n) { //递归边界
            for(int i = 0; i < cur; i++) {
                if(i) {
                    if( i % 64) {
                        if( i % 4 == 0) {
                            printf(" ");
                        }
                    }else {
                        printf("\n");
                    }
                }
                printf("%c",'A'+S[i]); //输出方案
            }
            printf("\n%d\n",cur);
            return 0;
        }
    
        for(int i = 0; i < l; i++) {
            S[cur] = i;
            int ok = 1;
    
            for(int j = 1; j*2 <= cur + 1; j++) { //尝试j*2的后缀
                int equal = 1;
    
                for(int k = 0; k < j; k++) {
                    if( S[cur-k] != S[cur-k-j]) {
                        equal = 0;
                        break;
                    }
                }
                if(equal) {
                    ok = 0;
                    break;
                }
            }
            if(ok && !dfs(cur+1)) {
                return 0;
            }
        }
        return 1;
    }
    int main() {
        while(scanf("%d%d",&n,&l) != EOF && (n || l) ) {
            cnt = 0;
            dfs(0);
        }
        return 0;
    }
    
    
    评论

报告相同问题?

悬赏问题

  • ¥15 高德地图点聚合中Marker的位置无法实时更新
  • ¥15 DIFY API Endpoint 问题。
  • ¥20 sub地址DHCP问题
  • ¥15 delta降尺度计算的一些细节,有偿
  • ¥15 Arduino红外遥控代码有问题
  • ¥15 数值计算离散正交多项式
  • ¥30 数值计算均差系数编程
  • ¥15 redis-full-check比较 两个集群的数据出错
  • ¥15 Matlab编程问题
  • ¥15 训练的多模态特征融合模型准确度很低怎么办