笑语语语 2021-10-21 19:34 采纳率: 100%
浏览 10
已结题

求解:杭电1070 Milk

Problem Description
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:

  1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
  2. Ignatius drinks 200mL milk everyday.
  3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
  4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.

Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.

Sample Input
2
2
Yili 10 500
Mengniu 20 1000
4
Yili 10 500
Mengniu 20 1000
Guangming 1 199
Yanpai 40 10000

Sample Output
Mengniu
Mengniu

Hint
In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case,
milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.


#include <iostream>
#include <cstring>
#include <math.h>
using namespace std;
int main(){
    int c;
    cin>>c;
    while(c--){
        int n,money,ml,maxml,ri,count=1;
        string name,maxname;
        float m;
        cin>>n;
        cin>>name>>money>>ml;
        ri=ml/200;
        while(ri==0){
            cin>>name>>money>>ml;
            ri=ml/200;
            count++;
        }
        if(ri>5)
        ri=5; 
        maxml=ml;
        maxname=name;
        m=1.0*money/ri;
        for(int i=count;i<n;i++){
            cin>>name>>money>>ml;
            ri=ml/200;
            if(ri==0)
            continue;
            if(ri>5)
            ri=5; 
            if((1.0*money/ri)<m || ((1.0*money/ri)==m && ml>maxml)){
                maxname=name;
                maxml=ml;
                m=1.0*money/ri;
            }
        }
        cout<<maxname<<endl;
    }
    return 0;
}

求解是哪里出了错

  • 写回答

0条回答 默认 最新

    报告相同问题?

    问题事件

    • 系统已结题 10月29日
    • 创建了问题 10月21日

    悬赏问题

    • ¥15 【求职】怎么找到一个周围人素质都很高不会欺负他人,并且未来月薪能够达到一万以上(技术岗)的工作?希望可以收到写有具体,可靠,已经实践过了的路径的回答?
    • ¥15 Java+vue部署版本反编译
    • ¥100 对反编译和ai熟悉的开发者。
    • ¥15 带序列特征的多输出预测模型
    • ¥15 Python 如何安装 distutils模块
    • ¥15 关于#网络#的问题:网络是从楼上引一根网线下来,接了2台傻瓜交换机,也更换了ip还是不行
    • ¥15 资源泄露软件闪退怎么解决?
    • ¥15 CCF-CSP 2023 第三题 解压缩(50%)
    • ¥30 comfyui openpose报错
    • ¥20 Wpf Datarid单元格闪烁效果的实现