paopyao 2021-11-20 15:17 采纳率: 100%
浏览 36
已结题

安装SQL驱动后,superset无法进入

问题:
mac,正常使用superset,在上传数据库时显示无法连接驱动,遂跳出并安装SQL驱动,安装完想要再打开superset就打不开了。如下:

(superset) fcy@fuchunyaodeMacBook-Pro ~ % superset
Traceback (most recent call last):
  File "/opt/anaconda3/envs/superset/bin/superset", line 8, in <module>
    sys.exit(superset())
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/click/core.py", line 829, in __call__
    return self.main(*args, **kwargs)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/flask/cli.py", line 586, in main
    return super(FlaskGroup, self).main(*args, **kwargs)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/click/core.py", line 781, in main
    with self.make_context(prog_name, args, **extra) as ctx:
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/click/core.py", line 700, in make_context
    self.parse_args(ctx, args)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/click/core.py", line 1209, in parse_args
    echo(ctx.get_help(), color=ctx.color)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/click/core.py", line 570, in get_help
    return self.command.get_help(self)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/click/core.py", line 975, in get_help
    self.format_help(ctx, formatter)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/click/core.py", line 1003, in format_help
    self.format_options(ctx, formatter)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/click/core.py", line 1137, in format_options
    self.format_commands(ctx, formatter)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/click/core.py", line 1184, in format_commands
    for subcommand in self.list_commands(ctx):
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/flask/cli.py", line 549, in list_commands
    self._load_plugin_commands()
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/flask/cli.py", line 523, in _load_plugin_commands
    self.add_command(ep.load(), ep.name)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2449, in load
    self.require(*args, **kwargs)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2472, in require
    items = working_set.resolve(reqs, env, installer, extras=self.extras)
  File "/opt/anaconda3/envs/superset/lib/python3.8/site-packages/pkg_resources/__init__.py", line 777, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (Jinja2 3.0.2 (/opt/anaconda3/envs/superset/lib/python3.8/site-packages), Requirement.parse('Jinja2<3.0,>=2.10.1'), {'Flask'})

目前完全不知道问题出在了哪里也不知道该如何解决

  • 写回答

1条回答

      报告相同问题?

      相关推荐 更多相似问题

      问题事件

      • 系统已结题 11月28日
      • 已采纳回答 11月20日
      • 创建了问题 11月20日

      悬赏问题

      • ¥15 uniapp实现钉钉【发起审批实例】上传文件到钉盘,后端为C#.Net处理
      • ¥15 求深信服VDI基准测试工具Sangfor DTP
      • ¥20 使用python中pandas进行数据分析
      • ¥20 使用python中pandas进行数据分析
      • ¥15 导入数据,并且以utf-8为编码格式,但是以上代码报错,求解答
      • ¥15 关于#游戏程序#的问题:端 玩wy服务器10几分钟闪退一次没有任何提示,连启动器一起闪退 本人电脑5800h 3060 16运内 win11 求解答
      • ¥15 做一个手游私服需要什么条件?
      • ¥15 关于企业微信,调用官方 微盘api 时候access_token过期的问题?
      • ¥15 请问这个C语言代码的界面怎样修改
      • ¥15 QT for Android 开发的App后台切换后卡死,没有响应