微笑精灵 2021-11-23 14:30 采纳率: 92.1%
浏览 69
已结题

maven版本过高,下载不了依赖。

问题遇到的现象和发生背景

我安装了3.8.3的maven,结果maven直接下载不下来依赖报错
Could not resolve dependencies for project com.cocosa.hrssc:hrssc:pom:1.0.0: Failed to collect dependencies at io.github.swagger2markup
:swagger2markup:jar:1.3.1 -> io.github.swagger2markup:markup-document-builder:jar:1.1.1 -> nl.jworks.markdown_to_asciidoc:markdown_to_asciidoc:jar:1.0: Failed to read artifact descript
or for nl.jworks.markdown_to_asciidoc:markdown_to_asciidoc:jar:1.0: Could not transfer artifact nl.jworks.markdown_to_asciidoc:markdown_to_asciidoc:pom:1.0 from/to maven-default-http-b
locker (http://0.0.0.0/): Blocked mirror for repositories: [aliyun-nexus (http://maven.aliyun.com/nexus/content/groups/public/, default, releases+snapshots), maven-public (http://192.1
68.1.21:9091/repository/maven-public/, default, releases+snapshots), maven-third-party (http://192.168.1.21:9091/repository/maven-third-party/, default, snapshots), maven-third-party-r
eleases (http://192.168.1.21:9091/repository/maven-third-party-releases/, default, releases), hsweb-nexus (http://nexus.hsweb.me/content/groups/public/, default, releases+snapshots)] -

[Help 1]

运行结果及报错内容

有什么不用降级的办法可以解决么?
我用的idea

  • 写回答

5条回答 默认 最新

  • I'Msohs 2021-11-23 15:11
    关注

    就是maven版本过高的问题,我之前也遇到过,换成低两个版本得

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(4条)

报告相同问题?

问题事件

  • 系统已结题 12月1日
  • 已采纳回答 11月23日
  • 创建了问题 11月23日

悬赏问题

  • ¥15 Mapreduce是正常的,在运行其他jar包时并没有任何问题,只是在做LogCount.jar 时出的问题。如图所示
  • ¥15 ImportError: DLL load failed while importing _iterative: 找不到指定的模块。
  • ¥15 如何通过交互分析得出某高危患者对放疗获益更多
  • ¥15 相关性分析中,p<0.05, r=0.29,怎么评价相关性呢
  • ¥15 docker部署Mongodb后输入命令报错?
  • ¥15 将下列流程图转变成python程序代码
  • ¥15 我需要全国每个城市的最新小区名字等数据。
  • ¥15 开发一个小区生态的小程序
  • ¥15 如何解决Excel中dependent dropdown list 的问题
  • ¥15 MddBootstrapInitialize2失败