qq_41887494
2021-12-09 15:43
采纳率: 66.7%
浏览 113

需要用qt的webassembly链接libvlc实现一个基于浏览器的视频播放器

问题遇到的现象和发生背景

公司安排个工作 想尝试用qt的webassembly链接libvlc实现一个基于浏览器的视频播放器

问题相关代码,请勿粘贴截图
运行结果及报错内容

用平常的qt编译后是可以正常播放视频的 但用qt的webassembly编译时 链接libvlc.lib和libvlccore.lib时报了文件格式错误

我的解答思路和尝试过的方法
我想要达到的结果

只要用qt的webassembly后 可以在浏览器正常运行并且播放视频就可以了 如果有人能帮助完成的话 除了这50酬谢 余额剩下的50也一并奉上

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • mideum 2021-12-09 16:05

    对webassembly不熟悉,仅探讨一下。
    这样你libvlc也需要编译webassembly版本才行吧,否则编译target不一样肯定link不了,但是libvlc能否支持webassembly是个问题。

    评论
    解决 1 无用
    打赏 举报

相关推荐 更多相似问题