ssaiguozhe
2019-05-10 10:53
采纳率: 0%
浏览 1.2k

caffe编译报错求助!!!

ubuntu18.04 CUDA9.1+cuDNN7.1.3 我的报错如下:
NVCC src/caffe/util/im2col.cu nvcc fatal : Option '--generate-code arch=', missing code Makefile:603: recipe for target '.build_release/cuda/src/caffe/util/im2col.o' failed make: *** [.build_release/cuda/src/caffe/util/im2col.o] Error 1 验证CUDA通过,但这个问题解决不了,求助!!!

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • threenewbee 2019-05-10 13:13

    18.04没有试过,但是在16.04+cuda8上是可以的,看下是不是你的依赖的库或者编译器的不兼容的不兼容问题

    具体编译参考这个步骤:https://www.zybuluo.com/hanxiaoyang/note/364737

    打赏 评论
  • ssaiguozhe 2019-05-10 14:16

    多谢!已经解决了。具体如下:
     仔细查看了一下 Makefile.config 中 CUDA_ARCH 设置未按规定设置:
        # CUDA architecture setting: going with all of them.  
        # For CUDA < 6.0, comment the *_50 through *_61 lines for compatibility.  
        # For CUDA < 8.0, comment the *_60 and *_61 lines for compatibility.  
        # For CUDA >= 9.0, comment the *_20 and *_21 lines for compatibility.  
        CUDA_ARCH := -gencode arch=compute_20,code=sm_20 \  
                -gencode arch=compute_20,code=sm_21 \  
                        -gencode arch=compute_30,code=sm_30 \  
                        -gencode arch=compute_35,code=sm_35 \  
                        -gencode arch=compute_50,code=sm_50 \  
                        -gencode arch=compute_52,code=sm_52 \  
                        -gencode arch=compute_60,code=sm_60 \  
                        -gencode arch=compute_61,code=sm_61 \  
                        -gencode arch=compute_61,code=compute_61
        因为我装的是CUDA9.1所以把下面这两行删除就可以
            -gencode arch=compute_20,code=sm_20 \  
            -gencode arch=compute_20,code=sm_21 \

    打赏 评论

相关推荐 更多相似问题