Hall_P
Hall_P
采纳率0%
2019-05-12 19:58

Linux下 tar指令解压压缩包遇到的问题 tomcat , mysql , 以及jdk

最近在Linux服务器上装tomcat,mysql, jdk的时候遇到很奇怪的一个问题。服务器是centOS7,
这些安装包都是下载到U盘后拷到服务器上的。都是XXX.tar.gz的文件,其中tomcat是8.x的版本,
jdk也是8,使用tar解压每次都失败,但是同时拷贝上去的redis的包却能够解压出来。

网上也看到了很多类似的问题以及解决方案,比方说tar后面不应该接z指令,需要拷到目录外去解压,但是尝试了都没有成功。通常情况下来说
tar -zxvf xxx.tar.gz是可以成功解压的,现在该指令的错误信息是这样的

gzip: stdin: not in gzip format

tar: Child returned status 1

tar: Error is not recoverable: exiting now

去掉z 也还是这样的错误,我试着用gzip -d来进行先解压也未成功。file filename看了一下文件格式也没有其他异常的信息,不知道各位大神最近在安装这些软件的时候有没有遇到这样的问题?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

2条回答

  • wengk2s wengk2s 2年前

    1 原因是这个压缩包没有用gzip格式压缩,所以不用加z指令。

    2 在解压tar.gz文件的时候报错 $ tar -zxvf clion-141.351.4.tar.gzgzip: stdin: not in gzip formattar: Child returned status 1tar: Error is not recoverable: exiting now.
    改为 $ tar -xvf clion-141.351.4.tar.gz,这样就可以了。

    3 把下载下来的文件重命名: mv apache-tomcat-6.0.26.tar.gz apache-tomcat-6.0.26.tar

    4 再执行解压命令: tar -zxvf apache-tomcat-6.0.26.tar

    点赞 评论 复制链接分享
  • ainiwmy ainiwmy 2年前

    Linux下安装jdk8步骤详述
    作为Java开发人员,在Linux下安装一些开发工具是必备技能,本文以安装jdk为例,详细记录了每一步的操作命令,以供参考。

    0.下载jdk8
    登录网址:http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
    选择对应jdk版本下载。(可在Windows下下载完成后,通过文件夹共享到Linux上)

    1. 登录Linux,切换到root用户

    su root 获取root用户权限,当前工作目录不变(需要root密码)

    sudo -i 不需要root密码直接切换成root(需要当前用户密码)

    1. 在usr目录下建立java安装目录

    cd /usr

    mkdir java

    3.将jdk-8u60-linux-x64.tar.gz拷贝到java目录下

    cp /mnt/hgfs/linux/jdk-8u60-linux-x64.tar.gz /usr/java/

    4.解压jdk到当前目录

    tar -zxvf jdk-8u60-linux-x64.tar.gz

    得到文件夹 jdk1.8.0_60

    5.安装完毕为他建立一个链接以节省目录长度

    (我没用这一步)
    ln -s /usr/java/jdk1.8.0_60/ /usr/jdk

    6.编辑配置文件,配置环境变量

    vim /etc/profile

    添加如下内容:JAVA_HOME根据实际目录来
    JAVA_HOME=/usr/java/jdk1.8.0_60
    CLASSPATH=$JAVA_HOME/lib/
    PATH=$PATH:$JAVA_HOME/bin
    export PATH JAVA_HOME CLASSPATH

    7.重启机器或执行命令 :source /etc/profile

    sudo shutdown -r now

    8.查看安装情况
    java -version

    java version "1.8.0_60"
    Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
    Java HotSpot(TM) Client VM (build 25.60-b23, mixed mode)

    可能出现的错误信息:

    bash: ./java: cannot execute binary file

    出现这个错误的原因可能是在32位的操作系统上安装了64位的jdk,
    查看jdk版本和Linux版本位数是否一致。
    查看你安装的Ubuntu是32位还是64位系统:
    sudo uname --m
    i686 //表示是32位
    x86_64 // 表示是64位
    转载的https://www.cnblogs.com/shihaiming/p/5809553.html希望对你有用

    点赞 评论 复制链接分享

相关推荐