关于framework的版本问题

我在vs上打开一个项目,他提示我计算机上没有4.6.1版本framework,安装4.6 1版本framework后,他还是提示我这个错,为什么啊

1个回答

估计是没有安装对,你安装下vs2017看看。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
Python+OpenCV计算机视觉

Python+OpenCV计算机视觉

高版本 .net framework开发的程序,运行在低版本 .net framework系统上会不会有问题?

![图片说明](https://img-ask.csdn.net/upload/201908/20/1566270625_629778.png) ![图片说明](https://img-ask.csdn.net/upload/201908/20/1566271277_264933.png) 用4.8版本开发的,在4.8以下版本的电脑上运行, ![图片说明](https://img-ask.csdn.net/upload/201908/20/1566270870_679522.png) 按照MSDN的说法应该会弹出要安装新版本的信息, 但实际测试下来并没有。为什么?会不会有什么隐患?

VS2012新建MFC项目时可以选择framework版本,但是无论选什么新建完成后依旧是基于4.0

VS2012新建MFC项目时可以选择framework版本,但是无论选什么新建完成后依旧是基于4.0 另外,我的电脑是win8的

.net framework 的版本伪装

各位大神怎么将电脑的 .net framework 的版本伪装为9.9的,![能让浏览器识别出来就OK图片说明](https://img-ask.csdn.net/upload/201507/22/1437577706_537302.png)

在XP系统上安装VS打包的程序,提示:此安装程序需要.Net Framework版本?

使用VS2010打包的程序,在WindowXP系统上安装时,提示:此安装程序需要.Net Framework版本4.0.请先安装.Net Framework版本,然后重新运行此安装程序。如下图 ![图片说明](https://img-ask.csdn.net/upload/201707/20/1500513066_931874.png) 求解决办法!!!!

MySql.Data.dll 8.0.12有合适.NET FRAMEWORK4.0项目引用的版本吗?

如题,官方网站下载mysql-connector-net-8.0.12.msi安装之后,MySql.Data.dll在路径...\MySQL\MySQL Connector Net 8.0.12\Assemblies\v4.5.2中,假如引用项目的目标框架是.NET Framework 4.5.2则正常,改为.NET Framework 4则编译报错,提示“ 1 未能找到类型或命名空间名称“MySql”(是否缺少 using 指令或程序集引用?)”,虽然在解决方案资源管理器-项目引用-MySql.Data右键菜单属性中看到该dll的运行时版本是v4.0.30319,但是若项目的目标框架设置为.NET Framework 4却会出错,只能设置为.NET Framework 4.5.2。我觉得安装之后MySql.Data.dll的路径目录说明了问题,为什么安装之后MySql.Data.dll只有在v4.5.2目录下?是MySql.Data.dll 8.0.12只能用于.NET Framework 4.5.2的项目吗?还是下载时根据我的电脑最高的Framework版本给我这个安装包?如果我的电脑最高的Framework版本是4.0,能下载到安装之后MySql.Data.dll在v4目录下的安装包吗?哪位热心的高手能帮忙验证一下?如果不更改电脑最高的Framework版本(因为修改卸载太麻烦了),能找到适合.NET Framework 4项目引用的mysql-connector-net-8.0.12.msi安装包或MySql.Data.dll 8.0.12吗? 哪位高手帮下忙,不胜感激!

Spring.net支持的framework高版本的问题

Spring.net有支持.net4的吗;我目前只看到只支持2.0的

关于EntityFrameWork连接Mysql8.0

关于EntityFrameWork连接Mysql8.0,请问下能连吗? mysql-for-visualstudio应该用什么版本呢?我用的1.2.8,提示连接程序不对。 mysql-connector-net用的8.0.11。在建立ado。net实体数据模型的时候不成功。

Framework7 2.2版本 日历控件 disabled 设置

Framework7 2.2版本 日历控件 我怎么才能让所有的周六 周天都变成灰色不可选择!

操作系统仅安装.NET Framework 4.6,能运行低于4.6版本编译的程序吗?

我的程序编译的目标框架是.NET Framework 4,假如我的电脑操作系统未安装.NET Framework 4,而是安装了更高级的版本.NET Framework 4.6,请问如果这样,运行时会提示必须安装.NET Framework 4吗?还是能直接运行在4.6上?

spring framework 5.1版本怎么用jsonp

spring framework 5.1版本移除了jsonp支持,理由是根据什么w3c的标准,不需要这么复杂。 然后我写的程序不想改界面指向升级5.1版本,有没有大佬有较好的解决方案。 我可以直接给结果前后拼接callback的方法,这个不够优秀,不想用。

android framework层面开发 style问题

现在开发中遇到如下问题:因为公司里面是对android的framework做了改动的,android.R.*对应的资源文件也被改动了。这样我在eclipse里面单独编译一个应用的时候就遇到某资源无法找到导致编译不过的问题。。。比如D:\workspace\MyApplication\res\values\styles.xml:25: error: Error retrieving parent for item: No resource found that matches the given name '@android:style/TextAppearance.StatusBar'. (因为我在自己应用的D:\workspace\MyApplication\res\values\styles.xml中有这么一行:<style name="TextAppearance.StatusBar.Title" [color=red]parent="@android:style/TextAppearance.StatusBar"[/color]> 引用到了framework中的资源文件。。) 请问如何改动android sdk里面的文件才能让这个项目编译通过? 目前已经将自己编译的android framewrok lib 包编译路径放在android.jar前面。 开始时以为可以通过替换D:\android-sdk-windows\platforms\android-8\data\res\values 路径下的文件解决这个问题。。结果发现依然不行。。 或者我想可以有第二条路,自己编一个SDK版本出来,然后在eclipse使用自己的这个SDK版本。。。不过不知道如何下手编。。。

windows .Net Framework 如何修复

前些天不知道动了什么地方,一些软件用不了,报错0xc0000135 。应该是.Net framework的问题。重新安装.net framework 提示:Microsoft .NET Framework 4.5已是此操作系统的一部分,但当前已关闭。若要启用 .NET Framework 4.5,请使用“控制面板”中的“打开或关闭 Windows 功能”,但是windows 功能中没有.Net framework 相关选项。尝试过修改注册表,NetFxRepairTool.exe修复工具,cleanup_tool.exe删除工具都不行,哪位知道怎么修复net framework。 ![图片说明](https://img-ask.csdn.net/upload/201810/08/1538968676_469887.jpg) ![图片说明](https://img-ask.csdn.net/upload/201810/08/1538968523_776936.jpg) ![图片说明](https://img-ask.csdn.net/upload/201810/08/1538968704_636950.jpg)

Windows server 2012 支持Framework和Office的最低版本是多少

Windows server 2012 支持Framework和Office的最低版本是多少。我搜了很多还是没 有准确的。请大家帮帮忙!最好能把网址wang发给我。谢谢!

OC工程项目导入Swift 版本的framework静态库。

#### 1、OC工程项目导入Swift 版本的framework静态库后,模拟器和真机编译都通过,但是模拟器环境下无法调用库里面的类,真机环境可以 #### 2、如果是Swift项目工程引入这个Swift静态库没有任何问题 1、 真机可以正常编译和调用Person ![图片说明](https://img-ask.csdn.net/upload/201903/29/1553841047_338039.png) 2、 不调用Person类模拟器可以正常编译, 但是调用Person后就 编译不通过 ![图片说明](https://img-ask.csdn.net/upload/201903/29/1553841059_194196.png)

EntityFramework安装出错

MVC EF学习中,安装EntityFramework出现如下错误,还望高手支招。多谢。 PM> Install-Package EntityFramework -Version 6.1.3 正在尝试收集与目标为“.NETFramework,Version=v4.5.2”的项目“MvcMovie”有关的包“EntityFramework.6.1.3”的依赖项信息 Install-Package : 无法加载源 https://api.nuget.org/v3/index.json 的服务索引。 发送请求时出错。 无法连接到远程服务器 由于连接方在一段时间后没有正确答复或连接的主机没有反应,连接尝试失败。 117.18.232.200:443 所在位置 行:1 字符: 16 + Install-Package <<<< EntityFramework -Version 6.1.3 + CategoryInfo : NotSpecified: (:) [Install-Package], Exception + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand 已用时间: 00:02:55.0807681

android5.1 编译framework层文件,生成的jar替换不成功

android5.1修改修改系统framework层后,执行mm命令,生成framework.jar,通过adb动态替换系统文件,发现替换不成功。(这个方法在android4.4是可以的)。如果android源码重新编译打包,也可以修改成功。请问问题出在那里?

vs2013创建的framework4.0项目在nuget.org里添加autofac报错

添加时 版本号显示的是4.6.1,引用报错。 首先,开始我的项目是framework4.5的,但后来知道对方系统是win2003的不支持4.5 ,只好降版本,网查了资料后,发现要重新建立4.0的项目 ,把原来的dll文件版本也要是4.0的才行,就重新添加引用了,但遇到autofac版本之前是4.5的,于是删除,重新在nuget.org里引用,默认版本是4.6.1的,导致引用时失败回滚,怎么解决?

怎么引用EntityFramework程序集

我建了三个层,DAL,Model, BLL Model用的是EF 然后在Model中添加了一个方法,发现有未引用程序集 ![图片说明](https://img-ask.csdn.net/upload/201601/23/1453562429_789278.jpg) 我对比了下model和DAL程序集引用的区别发现Model在添加EF框架的时候自动引用了 EntityFramework程序集而DAL层没有 ![图片说明](https://img-ask.csdn.net/upload/201601/23/1453562715_226439.jpg) 我想手动引用程序集发现打不到这个程序集???? 版本: VS是2015,EF是6.13, .net框架是4.52, 我感觉EF版本太高的,可能某个地方 识别出来的只是6.0.0.0 求大神帮忙,怎么最简单方法引入EntityFramework程序集

怎么下载并安装web farm framework 2.2?

我从巨硬上下载web farm framework 2.2的安装软件后,直接安装,弹出需要web platform。 于是又分别下载了web platform 3.0 和5.0 ,但是这两个版本上的web farm framework版本都是1.1。 实在没辙了。

2019 Python开发者日-培训

2019 Python开发者日-培训

150讲轻松搞定Python网络爬虫

150讲轻松搞定Python网络爬虫

设计模式(JAVA语言实现)--20种设计模式附带源码

设计模式(JAVA语言实现)--20种设计模式附带源码

YOLOv3目标检测实战:训练自己的数据集

YOLOv3目标检测实战:训练自己的数据集

java后台+微信小程序 实现完整的点餐系统

java后台+微信小程序 实现完整的点餐系统

三个项目玩转深度学习(附1G源码)

三个项目玩转深度学习(附1G源码)

初级玩转Linux+Ubuntu(嵌入式开发基础课程)

初级玩转Linux+Ubuntu(嵌入式开发基础课程)

2019 AI开发者大会

2019 AI开发者大会

玩转Linux:常用命令实例指南

玩转Linux:常用命令实例指南

一学即懂的计算机视觉(第一季)

一学即懂的计算机视觉(第一季)

4小时玩转微信小程序——基础入门与微信支付实战

4小时玩转微信小程序——基础入门与微信支付实战

Git 实用技巧

Git 实用技巧

Python数据清洗实战入门

Python数据清洗实战入门

使用TensorFlow+keras快速构建图像分类模型

使用TensorFlow+keras快速构建图像分类模型

实用主义学Python(小白也容易上手的Python实用案例)

实用主义学Python(小白也容易上手的Python实用案例)

程序员的算法通关课:知己知彼(第一季)

程序员的算法通关课:知己知彼(第一季)

MySQL数据库从入门到实战应用

MySQL数据库从入门到实战应用

机器学习初学者必会的案例精讲

机器学习初学者必会的案例精讲

手把手实现Java图书管理系统(附源码)

手把手实现Java图书管理系统(附源码)

极简JAVA学习营第四期(报名以后加助教微信:eduxy-1)

极简JAVA学习营第四期(报名以后加助教微信:eduxy-1)

.net core快速开发框架

.net core快速开发框架

玩转Python-Python3基础入门

玩转Python-Python3基础入门

Python数据挖掘简易入门

Python数据挖掘简易入门

微信公众平台开发入门

微信公众平台开发入门

程序员的兼职技能课

程序员的兼职技能课

Windows版YOLOv4目标检测实战:训练自己的数据集

Windows版YOLOv4目标检测实战:训练自己的数据集

HoloLens2开发入门教程

HoloLens2开发入门教程

微信小程序开发实战

微信小程序开发实战

Java8零基础入门视频教程

Java8零基础入门视频教程

相关热词 c#树形选择 c#中类图的使用方法 c# 传参 调用exe c# 怎么定义方法 c# 修改本地时间 c#前台怎么读取资源文件 c# xml转list c#实现框选截图 m*m乘法表c# c# 乘法99表
立即提问