vue项目中的依赖去哪里找?

新建了一个vue项目,启动时报错,说缺少vue-router,
这个vue-router依赖在哪里可以找到?



在java中缺少依赖,我们会去
https://mvnrepository.com/ 找相应版本的依赖包,但vue的依赖包在
哪里找,不晓得啊


(我知道要在package.json中进行配置。)

3个回答

已经找到解决方案,在下面这个网站自己搜,可以看到所有版本号,然后自行选择
https://www.npmjs.com/

直接 npm install vue-router 安装就行了

lllomh
lllomh 回复和Java狼狈为奸: npm install vue-router 后面带上版本就行了
8 个月之前 回复
Myc_CSDN
和Java狼狈为奸 谢谢回答,但是这样安装的话他会默认给我装最新的版本,但我其实需要的并不是最新的版本怎么办?
8 个月之前 回复

我个人常用的方法两种:

1.npm i 需要的依赖 --save
2.在package.json 手动输入你要的依赖,以及版本,npm i
图片说明

qq_41046662
易烊千玺的女朋友 你对一楼的回复是“但我其实需要的并不是最新的版本怎么办”,我以为你有自己想要的版本要下载呢,如果不知道版本号可以去该依赖的官网查看
8 个月之前 回复
Myc_CSDN
和Java狼狈为奸 谢谢回答,但是我想问的是,这个版本号你是在哪里找的?
8 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问