☜百du不侵✘ 2022-02-11 11:56 采纳率: 100%
浏览 353
已结题

ImportError: /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found,如何解决?

在Ubuntu系统中,通过pycharm编译代码时出现了这个问题。

img

通过在网上查询,我在 https://blog.csdn.net/qq_25738937/article/details/81837735
这里得到了答案。其中该博客的评论提出了解决办法。
原因是qmake系统使用的QT版本过低,需要和上面图片中提示的QT版本一致(或更高),要升级qt5-base软件包。可我不知道qt5-base的位置及升级它的方法。

img

我想知道qt5-base软件包在哪里及怎么去升级它,或者这个问题的其他解决方案。

  • 写回答

2条回答

      报告相同问题?

      相关推荐 更多相似问题

      问题事件

      • 系统已结题 2月19日
      • 已采纳回答 2月11日
      • 创建了问题 2月11日

      悬赏问题

      • ¥15 做一个手游私服需要什么条件?
      • ¥15 关于企业微信,调用官方 微盘api 时候access_token过期的问题?
      • ¥15 请问这个C语言代码的界面怎样修改
      • ¥15 QT for Android 开发的App后台切换后卡死,没有响应
      • ¥15 【Coppeliasim】利用remoteApi实现Coppeliasim与C++程序的数据通讯
      • ¥15 Spring Boot 服务迁移到 k8s , 配置文件 eureka.instance.prefer-ip-address = true,注册在 eureka 依然是服务名称
      • ¥15 No module named 'pyLDAvis'
      • ¥15 Microsoft.ReportViewer.WinForms 预览打印显示
      • ¥15 C#点到对岸的距离,各距离线段即垂直于下方斜线
      • ¥50 R语言时间序列 滚动窗口预测