cczlp 2022-03-10 10:08 采纳率: 0%
浏览 9

macOS12.2.1, XCode13.2.1, QT 15.5, 编译失败?

提示:error: The Legacy Build System will be removed in a future release. You can configure the selected build system and this deprecation message in File > Project Settings.

 

新建QT工程, 直接编译,就出现这个提示, 应该如何解决?

  • 写回答

1条回答 默认 最新

  • m0_54204465 2023-01-14 20:31
    关注

    这个错误提示表明,您正在使用QT 15.5和Xcode 13.2.1在macOS 12.2.1上编译工程,但是因为使用了遗留的构建系统,导致编译失败。

    解决方法是:
    1.打开Xcode,在工程文件中,找到Project Settings。
    2.选择新的构建系统,可以使用Xcode的新构建系统或者使用QT提供的qmake。
    3.设置新的构建系统并重新编译工程。

    如果依然不能编译成功,建议检查QT、Xcode、macOS的版本是否相匹配,并确保安装了正确的驱动。

    评论

报告相同问题?

问题事件

  • 创建了问题 3月10日

悬赏问题

  • ¥15 u盘问题:盘符不显示 无媒体
  • ¥50 R语言读取nc按月均值转为tif
  • ¥30 智能车串级pid调参
  • ¥15 visual studio code翻译老是错误
  • ¥20 卫星测高数据的高程转换
  • ¥15 爬取招聘网站数据信息
  • ¥15 安装完tensorflow,import tensorflow as tf后报错,如何解决?
  • ¥15 ultralytics库导出onnx模型,模型失去预测能力
  • ¥15 linux下点对点协议连接2个USB串口的硬件流量控制问题
  • ¥15 SQL数据自动生成问题