Crimer_ 2022-04-07 10:11 采纳率: 100%
浏览 288
已结题

Maven项目如何选择合适版本依赖(如JUnit、mybatis等)

如题,在编写Maven项目的pom.xml文件进行导入依赖时,如何选择合适版本,或者如何了解不同版本之间的兼容性进行选择,避免不同版本之间的不兼容性导致程序运行出现较大的BUG。
如下图,选择mybatis版本时有多个候选项,此时若导入MySQL、JUnit等工具,该如何搭配相互之间合适的版本避免不兼容。

img

  • 写回答

2条回答 默认 最新

  • BCS-点心 2022-04-07 11:05
    关注

    1.不要看提示,那只是辅助手段
    2.导入jar包时,看发布日期,前后相差不要超过1年,都不会有问题
    3.大部分jar包会依赖其它jar包,maven会把相关的都导入,所以不要重复导入了
    4.不要迷信新版本,程序开发要的是稳定,除非现有版本有漏洞,否则用最新版本没必要

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 4月15日
  • 已采纳回答 4月7日
  • 创建了问题 4月7日

悬赏问题

  • ¥20 ML307A在使用AT命令连接EMQX平台的MQTT时被拒绝
  • ¥20 腾讯企业邮箱邮件可以恢复么
  • ¥15 有人知道怎么将自己的迁移策略布到edgecloudsim上使用吗?
  • ¥15 错误 LNK2001 无法解析的外部符号
  • ¥50 安装pyaudiokits失败
  • ¥15 计组这些题应该咋做呀
  • ¥60 更换迈创SOL6M4AE卡的时候,驱动要重新装才能使用,怎么解决?
  • ¥15 让node服务器有自动加载文件的功能
  • ¥15 jmeter脚本回放有的是对的有的是错的
  • ¥15 r语言蛋白组学相关问题