在idea中有关html5中的一些css与js问题

我直接在codepen中copy了一些代码下来,包括css、js与一些html页面,但是报错了,有提示js版本不对,也有提示css错误,我就不是很明白idea中创建maven项目这些基本的js、css都没有引入么?还是说需要自己手动引入一些文件啊?
图片说明

图片说明

还是说codepen网站上用的js与css依赖一些其他的文件什么的?有大神帮忙解释一下么?

2个回答

从你最后一个图看,你的javascript没有写完,也没有闭合</script>标签,就又有了。你是不是粘贴不完整。

chdliudong
chdliudong 是闭合的啊,它提示我js版本不对
大约一年之前 回复

你怕不是没有导入CSS、js、jq资源文件哦,maven只负责jar包,不负责这些资源文件

Demo_Null
Demo_Null 回复chdliudong: 需要手动导入,使用的什么框架就导什么
大约一年之前 回复
chdliudong
chdliudong 这些资源文件idea里有带么?还是需要自己手动导入进去啊
大约一年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐