4jie 2022-04-14 22:57 采纳率: 71.4%
浏览 161
已结题

android.database.sqlite.SQLiteException: Can't downgrade database from version 2 to 1

android.database.sqlite.SQLiteException: Can't downgrade database from version 2 to 1这个异常是有什么可能的原因啊?还有就是可以怎么解决?以下是android stduio的报错位置

/**
     * 封装可写数据库对象db的创建
     */
    private SQLiteDatabase getDB(Context context) {
        MyDatabaseHelper myDatabaseHelper = MyDatabaseHelper.getInstance(context);
        return myDatabaseHelper.getWritableDatabase();//报错位置
    }
  • 写回答

2条回答

      报告相同问题?

      问题事件

      • 系统已结题 4月23日
      • 已采纳回答 4月15日
      • 创建了问题 4月14日

      悬赏问题

      • ¥40 python,计算机程序运行结果很奇怪
      • ¥15 有关时间计算器的问题
      • ¥200 Chrome浏览器自动保存密码需要解密!来人
      • ¥18 关于#c语言#的问题:如何把下面几个代码放在一起编序号,然后输入对应数字运行对应代码,还可以返回重输
      • ¥30 windows下无法运行go test的问题
      • ¥15 多个Rigify骨骼 导入一起 后 没有 控制器面板
      • ¥15 想问一下sprak ada语言的pre和post怎么设
      • ¥15 使用python将分子模拟输出.gro文件
      • ¥15 港诡实录的背包系统拆解
      • ¥15 宽带IP网络路由器的初始路由表和最终路由表