蒻姬★彡 2022-04-18 17:43 采纳率: 100%
浏览 217
已结题

树莓派4B安装MariaDB失败

换源后安装安装MariaDB一直显示这个,求解求解,
正在读取软件包列表.完成
正在分析软件包的依赖关系树.完成
正在读取状态信息. 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:
下列软件包有未满足的依赖关系:
libdbi-perl : 依赖: perlapi-5.28.1
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系

img

  • 写回答

1条回答 默认 最新

  • 避凉闲庭 2022-04-18 18:08
    关注
    1. 排查perlapi这个是否已经安装,若已安装建议卸载后重新安装mariadb,会存在版本错误的情况
    2. 就是切换一下安装源
    3. 安装aptitude来重新计算安装方案
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

问题事件

  • 系统已结题 4月27日
  • 已采纳回答 4月19日
  • 创建了问题 4月18日

悬赏问题

  • ¥15 如何删除这个虚拟音频
  • ¥50 hyper默认的default switch
  • ¥15 网站打不开,提示502 Bad Gateway
  • ¥20 基于MATLAB的绝热压缩空气储能系统代码咨询
  • ¥15 R语言建立随机森林模型出现的问题
  • ¥15 中级微观经济学,生产可能性边界问题
  • ¥15 TCP传输时不同网卡传输用时差异过大
  • ¥15 请各位看看我写的属于什么算法,或者有更正确的写法?
  • ¥15 html5 qrcode 扫描器
  • ¥15 爬取网页信息并保存需要完整代码