onkmtxp
2019-07-18 19:27
采纳率: 100%
浏览 956

·Robotframework」运行ride.py 报错 麻烦大神们看一下!

环境:Ubuntu 16.04

折腾了好久pip install robotframework-ride 才成功
运行ride.py又又又报错了 心累
麻烦各位帮我看看 指点迷津

pip install robotframework-ride
提示
Looking in indexes: https://pypi.tuna.tsinghua.edu.cn/simple
Requirement already satisfied: robotframework-ride in /usr/local/lib/python2.7/dist-packages (1.7.4b1.dev1)
Requirement already satisfied: wxPython in /usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode (from robotframework-ride) (2.8.12.1)
Requirement already satisfied: PyPubSub in /usr/local/lib/python2.7/dist-packages (from robotframework-ride) (3.3.0)
Requirement already satisfied: Pygments in /usr/local/lib/python2.7/dist-packages (from robotframework-ride) (2.4.2
ride.py后

图片说明

报错:Traceback (most recent call last):
File "/usr/local/lib/python2.7/dist-packages/robotide/__init__.py", line 83, in main
run(inpath, not noupdatecheck, debug_console)
File "/usr/local/lib/python2.7/dist-packages/robotide/
_init__.py", line 112, in run
ride = RIDE(inpath, updatecheck)
File "/usr/local/lib/python2.7/dist-packages/robotide/application/application.py", line 45, in __init
_
wx.App.__init__(self, redirect=False)
File "/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7981, in init
self._BootstrapApp()
File "/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7555, in BootstrapApp
return _core
.PyApp__BootstrapApp(*args, **kwargs)
File "/usr/local/lib/python2.7/dist-packages/robotide/application/application.py", line 55, in OnInit
self.frame = RideFrame(self, self._controller)
File "/usr/local/lib/python2.7/dist-packages/robotide/ui/mainframe.py", line 173, in init
self.Bind(wx.EVT_DIRCTRL_FILEACTIVATED, self.OnOpenFile)
AttributeError: 'module' object has no attribute 'EVT_DIRCTRL_FILEACTIVATED'

麻烦各位了!!非常感谢!!

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • onkmtxp 2019-07-19 16:05
    已采纳

    将wxpython版本换成4.0.6即可打开ride

    版本对应如下:
    robotframework-ridges (1.7.4b1.dev1)
    wxPython in /usr/local/lib/python2.7/dist-packages (from robotframework-ride) (4.0.6)

    点赞 评论
  • blownewbee 2019-07-18 20:15

    python版本是否合乎要求?你用的2.7?试试看3.6呢

    点赞 评论

相关推荐 更多相似问题