BZeHong
2019-07-19 11:35
采纳率: 66.7%
浏览 1.9k
已采纳

SpringBoot项目打成jar包后运行报错:defaultValidator创建失败?

百度了一下,说是tomcat版本太低要升级到8,可我引入的spring-boot-starter-parent 2.1.5版本,看了下它的pom文件,tomcat版本是9.0.....是因为太高了吗?

pom依赖为:

<parent>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-parent</artifactId>
        <version>2.1.5.RELEASE</version>
        <relativePath /> <!-- lookup parent from repository -->
    </parent>

具体错误提示信息:

org.springframework.beans.factory.BeanCreationException: 

Error creating bean with name 'defaultValidator' defined in class path resource [org/springframework/boot/autoconfigure/validation/ValidationAutoConfiguration.class]: Bean instantiation via factory method failed; 

nested exception is org.springframework.beans.BeanInstantiationException: Failed to instantiate [org.springframework.validation.beanvalidation.LocalValidatorFactoryBean]: Factory method 'defaultValidator' threw exception; 

nested exception is java.lang.NoClassDefFoundError: org/hibernate/validator/internal/engine/ConfigurationImpl
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • BZeHong 2019-07-19 12:12
    已采纳

    解决了...把spring-boot-starter-parent版本升级到最新版 2.1.6.RELEASE,运行成功

    打赏 评论

相关推荐 更多相似问题